Free Support Forum - aspose.com

Aspose.pdf infinite looping

Hi,

We are using the Aspose.PDF tool to convert the front page of a PDF into an image. We need this for various reasons, but for instance as a thumbnail.

When converting many PDFs at a time, we are experiencing issues with the Aspose.PDF tool stalling or going into some sort of infinite looping.

We have to kill the process to make it start again.

Thoughrough investigation shows us that the process dies in the Aspose.PDF code. We have tried many different approaches involving both PDF to PNG and PDF to JPEG. All seems to have the same issue.

Looking at the release notes for v. 20.3, there seem to have been similar issues with TIF and HTML conversion. These are issues like:

  • PDFNET-46020
  • PDFNET-47711
  • PDFNET-47335

I do not know if these are related, but from the release notes it seems to be the same type of problem.

I have managed to reproduce the problem in a small local application that I have shared this thread. It runs for a few iterations and then stops. It also includes the PDF’s that are troublesome.

What happens is it runs for a short while (up to 100 iterations) and then it stalls. What I see is the conversion creates a 0 byte file that seems to be locked by the application. From there, it just hangs infinitely. I think it could be because of it running in parallel, but I am not sure.

You can find the application here

Any help would be much appreciated. Thanks in advance!

/Magnus

@madjufra

Thanks for contacting support.

We were able to notice the issue that you have mentioned and logged it as PDFNET-47996 in our issue tracking system. We will definitely look into its details and keep you posted with the status of its rectification. Please be patient and spare us some time.

We are sorry for the inconvenience.

@asad.ali,

Thanks for the response. We have found a workaround on this issue for now, so we can move on.

It would be awesome if this thread could be updated with progress, as we’d like to use Aspose.

Thanks,
Magnus

@madjufra

It is good to know that you were able to resolve your issue. It would also be great if you could share what workaround you adopted to overcome the issue as it would be helpful during investigation of the logged ticket. We will surely keep you informed about status of ticket resolution.

@asad.ali, I am almost certain our workaround is not going to help you, because we used ImageMagick for PDF conversion instead, as we had a production environment not working.

Sorry.

Hi @asad.ali,

Any updates on this? This is becoming more and more a problem for a handful of our clients.

@madjufra

Regretfully, the issue is not yet resolved due to other high priority issues. Please note that the issue was logged under normal support where issues are resolved on first come first serve basis and have low priority. However, we have recorded your concerns and will surley consider them during issue investigation. We will let you know as soon as we have some updates in this regard. Please spare us some time.

We are sorry for the inconvenience.

@asad.ali, Is this solved? We would really appreciate some progress on this soon. We payed a significant amount of money for something that does not work.

@madjufra

We are afraid that earlier logged ticket is not yet resolved. We definiely understand your concerns and value them. However, issues are resolved on fair policy of first come first serve. We will inform you as soon as we make some certain progress towards resolution of the issue. We greatly appreciate your comprehension and patience in this matter.

We are sorry for the inconvenience.