We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Pdf.Kit Running in Solaris10 with Mono

There is an issue appear:

System.IO.IOException: Read pdf error:Trailer object is null.: v4.3.0.0
at xeb116a323308e2f7.x7759a935a2782a02.readPdf () [0x00000]
at xeb116a323308e2f7.x7759a935a2782a02..ctor (System.IO.Stream is_Renamed, System.SByte[] ownerPassword) [0x00000]
at xeb116a323308e2f7.x7759a935a2782a02..ctor (System.IO.Stream is_Renamed) [0x00000]
at Aspose.Pdf.Kit.PdfFileEditor.Insert (System.IO.Stream inputStream, Int32 insertLocation, System.IO.Stream portStream, System.Int32[] pageNumber, System.IO.Stream outputStream) [0x00000]

OS: Solaris-SPARC 10

.NET version is Mono 2.4.2.3

but the it works at Windows .NET 3.5

Hi Walter,

Thank you very much for considering Aspose.

I’m sorry to share with you that Mono environment is not fully supported yet. We have already logged a related issue as PDFKITNET-18915 in our issue tracking system. Our team is working on this issue and we’re very much hopeful that complete Mono support will be available in our Q2’2011 release.

Nevertheless, as we’re fixing various issues gradually, you might try our latest version. If it still doesn’t resolve your issue then please do let us know.

We’re sorry for the inconvenience.
Regards,

I have tried the latest version of PDF Kit V5.0 published on 11/11/2010, and still cannot resolve the issue. And is there any page insertion method at Aspose.PDF for .net ?

Hi Walter,

I’m sorry that the latest version didn’t resolve your issue either; please spare us some time so that our team would be able to resolve the above mentioned issue and provide complete support for Mono. Moreover, I’m afraid, PdfFileEditor.Insert is the only method provided by Aspose.Pdf.Kit to insert a page to a PDF file; Aspose.Pdf is a component which only allows you to create a PDF file from scratch, so it can’t provide a facility to add pages to an existing PDF file.

We’re sorry for the inconvenience. If you have any further questions, please do let us know.
Regards,

It’s after 2Q2011…has this been fixed yet? What features of PDF aren’t yet supported on Mono; can one reliably generate PDF’s from DOC/DOCX?

Hi,

We have introduced merged Aspose.Pdf for .NET, which contains features of Aspose.Pdf and Aspose.Pdf.Kit. After initial testing, we have found this version working on mono. Please try this version at your end. As far as, DOC/DOCX to PDF conversion is concerned, it is supported by Aspose.Words for .NET. You may further discuss this feature with Aspose.Words team.

I hope this helps. If you find any further questions, please do let us know.
Regards,