We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose PDF license loading for text extraction at application start-up not working

I am using aspose pdf 21.2 and have a aspose total license. In my spring boot application I am trying to load the license on start-up and then extract the text on every incoming api request. What I observe is that even though I load the license on start-up of the application I also need to do it every time i extract the text,. My question on stackoverflow here https://stackoverflow.com/questions/75363386/aspose-license-not-working-correctly-for-spring-boot-application

Is there a workaround for this or is it an issue with the aspose library?


This is unexpected behavior, as it is not necessary to load the license every time.

Have you tried using your license with the most updated version of Aspose?

How old is your license?

Is it valid for version 21.2?

You can check when your subscription expires, just open the license file in Notepad and see the SubscriptionExpiry field. Please do not modify the license and it will stop working.


License is valid till Feb 28th and I can extract text from PDF without any issues.
Only thing is I need to load the License for each request which is quite expensive in terms of performance of the application. The latest version doesn’t work with the current license, when my organisation renews the license I can try upgrading the version.

Would you mind trying to update your version to a newer one?

You are using 21.2 when current we are on the 23.1.

Can you try doing that and see if you still have the same issue?

I also would like to see the code and the PDF that you are loading. So far I have not been able to replicate the issue.

It worked with 23.1


Glad to hear it worked. I would suggest you get the latest version of the product as long as your license have access to them. They are released monthly and contain lots of improvements and fixes.