We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.PDF .Net Core problem with Linux

Hello,
I’m having a problem while trying to extract the text from a pdf with aspose, while using .NET core on Linux x64, Amazon Linux 2, Aspose version 18.7.0 the following exception is thrown when the method page.Accept(TextAbsorber) is called.

at .(Operator )
at .()
at ​ .(BaseOperatorCollection , Resources , Page )
at ​ .(BaseOperatorCollection , Resources )
at ​ .()
at ​ …ctor(Page , TextSearchOptions , Boolean )
at ​ …ctor(Page , TextSearchOptions )
at Aspose.Pdf.Text.TextAbsorber.Visit(Page page)
at Aspose.Pdf.Page.Accept(TextAbsorber textAbsorber)

When I run it on my Windows environment the process works fine.

Thank you.

@paulofbdc

Please make sure to install libgdiplus package in your Linux environment along with Microsoft Essential Fonts (msttcorefonts package). Furthermore, if you notice that installed fonts are present in a directory other than “/usr/share/fonts/truetype/msttcorefonts”, please use the below code to set directory of the fonts for the API.

Aspose.Pdf.Text.FontRepository.Sources.Add(new FolderFontSource("<user's path to ms fonts>"));

Please implement our suggestion along with using the latest version of the API i.e. 21.5 and let us know in case you face any issue by sharing complete sample code and PDF document.

Hello,
I tried it, the error changed but it still didn’t worked. Now it says this:

at . ()
at .(FontSource )
at .()
at .()

As for the latest version of the API, my license only works until 18.7, is there a way to get a trial license for the latest version so I can test to see if it solves the problem?

Thank you

@paulofbdc

The error shows that the API is unable to find the targeted font in the system where you are processing the PDF file. Furthermore, you can surely test the latest version by using a temporary 30-days free license and let us know in case issue still persists by sharing a sample PDF along with complete sample code.