We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.PDF renders forms and images with a black background underneath

I’m using Aspose.PDF 21.7;
I’m running the application in Linux with .Net Core 3.1, while I have also tried .Net Core 2.0/2.1, problem not solved;

Detailed package info:
libpng.x86_64 2:1.5.13-8.el7 @base
libpng-devel.x86_64 2:1.5.13-8.el7 @base
libjpeg-turbo.x86_64 1.2.90-8.el7 @base
libjpeg-turbo-devel.x86_64 1.2.90-8.el7 @base
libtiff.x86_64 4.0.3-35.el7 @base
libtiff-devel.x86_64 4.0.3-35.el7 @base
libgdiplus.x86_64 6.0.5 @base

Here is my sample:Sample.pdf (60.4 KB)
Here is the output:f8fc894b-6709-4a28-a9d6-26d09ba07ebc.jpg (420.0 KB)
Here is the code:

JpegDevice renderDevice = new JpegDevice(resolution)
    RenderingOptions = { UseFontHinting = true, UseNewImagingEngine = true }
using (MemoryStream imageMemoryStream = new MemoryStream())
    renderDevice.Process(targetPage, imageMemoryStream);


A ticket with ID PDFNET-50779 has been created in our issue tracking system to further investigate the issue on our end. This thread has been linked with the issue so that you may be notified once the issue will be fixed.