We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.PDF version 4.9 and version 6.6

We have a large website that has multiple applications (separate .csproj’s). Many of those projects use Aspose.PDF, and the .dll is in a common /bin directory.

I now need to extract .xfa data from a .pdf and need a newer version of Aspose.PDF. I have tested using version 6.6 and it works wonderfully.

Since 6.6 has “breaking changes” from 4.9, we cannot simply replace the newer .dll in the /bin directory. We would need to re-work old applications.

I would like to know if we can do a side-by-side installation in the GAC of the two versions?

Thank you for any suggestions.

Hi Randall,

Thank you for using our products.

I am very sorry to share with you that you cannot use multiple versions of Aspose at a time. However, you are using too old version of Aspose.Pdf for .NET, we would appricaite, if you try to use the latest version of Aspose.Pdf for .NET v6.8. In latest version of Aspose you can get a lot of new features. Moreover, you can also use all the features of Aspose.Pdf.Kit for .NET available in new versions of Aspose.Pdf for .NET v6.x.

We apologize for your inconvenience.

Thanks & Regards,

rbiagi:
Since 6.6 has “breaking changes” from 4.9, we cannot simply replace the newer .dll in the /bin directory. We would need to re-work old applications.

Hello Randall,

Thanks for using our products.

Can you please share some details regarding the issues that you are facing when using the latest release version. We will try our level best to get these issues resolved. We are really sorry for your inconvenience.