We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.pdf with .net Core 3.1 problem remotingservice

I am trying to deploy aspose.pdf on a .net Core 3.1 application but have the following error when using setlicence like this:

Aspose.Pdf.License license = new Aspose.Pdf.License();
license.SetLicense(fullLicenceFileName);

The runtime error is:

System.TypeLoadException: ‘Could not load type ‘System.Runtime.Remoting.RemotingServices’ from assembly ‘mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’.’

The Aspose.PDF.dll version is 20.11.0.0

Any ideas?

Thank you

Ha ha - just solved it myself - need to download the aspose.pdf 20.12 from nuget and not reference as a dll …

Just in case someone else hits this issue

@thealster

It is nice to hear that your issue got resolved and thanks for sharing the steps that you performed. Please feel free to let us know in case you need any assistance.

@thealster, @asad.ali this didn’t work for us. We have the paid license and are updating from net472 to netcoreapp3.1. The same error when trying to SetLicense. We’ve tried it by file name and by file stream.

What do you mean “from nuget and not reference as a dll”. We are only using the nuget package reference and still get this error.

We are currently using Aspose.PDF 21.7

@shanabus

Could you please share the complete environment details in which you are facing the issue? Please share the complete error message with stack trace information. It would also be helpful if you can please share a sample console application that is able to reproduce the issue. We will test the scenario in our environment and address it accordingly.