Free Support Forum - aspose.com

Aspose rendered text which is hidden in Excel

Hi,



When rendering an Excel sheet into image, I found when there are text which is wider than its column width, the image rendered will be different from the Excel sheet and also different from copy/paste from Excel manually.



Code:



var book = new Workbook(@“test.xlsx”);

Worksheet sheet = book.Worksheets[0];

var options = new ImageOrPrintOptions

{

ImageFormat = ImageFormat.Emf,

OnlyArea = false,

OnePagePerSheet = true

};

SheetRender sr = new SheetRender(sheet, options);

sr.ToImage(0, @“out.emf”);



You can find in text.xlsx, Cell B1 has a value ‘0’ but because of container not big enough, the character is hidden. But in the rendered image, the character appears.



Could you check this issue to see if Aspose can behave the same as Office there?



Thanks,

Hi John,


Thank you for contacting Aspose support.

I have evaluated the presented scenario while using the latest version of Aspose.Cells for .NET 8.9.2.7, and I am able to replicate the said behaviour on my side. In order to further investigate the matter, I have logged this incident as CELLSNET-44733 in our bug tracking system. Please spare us little time to analyze the case and revert back with updates in this regard.

Hi again,


This is to update you that we have resolved the problem logged earlier as CELLSNET-44733. We will shortly share the fix here for your testing.

Hi,


Please try our latest version/fix: Aspose.Cells for .NET 9.0.1.0 against the issue logged earlier as “CELLSNET-44733”.

Your issue should be fixed in it.

Let us know your feedback.

Thank you.

Hi,



Thanks for your update.



I’ve tried 9.0.1.0 with the test.xlsx I provided for you and it worked. However, when I tested with another sample .xlsx file the issue remains.



I’ve attached the new test file, could you have a look into that?



Thanks

Hi,


Thanks for the template file.

I have tested your scenario/ case using your newly attached file “test3.xlsx”. I reproduced the same issue with the file. I checked, in Column E, some cells has numeric data which are not visible in MS Excel. But, the output image has these numeric values partially. I have reopened your issue “CELLSNET-44733” again.

We will look into it to figure it out soon.

Thank you.

Hi John,


This is to update you that the ticket logged earlier as CELLSNET-44733 has been marked resolved. We will shortly share the fix here for your testing.
Hi,

Thanks for using Aspose.Cells.

Please download and try the latest fix: Aspose.Cells for .NET v9.0.5.0 or Aspose.Cells for .NET v9.0.5.0 (.NET 4.0) and let us know your feedback.

Hi,

Thanks for your update. I’ve tested Aspose.Cells for .NET v9.0.5.0 (.NET 4.0) with the test files and did not see the issue again.

Thanks very much

Hi John,


It is good to know that you are up & running again. Please feel free to get in touch if you require our further assistance with Aspose APIs.

The issues you have found earlier (filed as CELLSNET-44733) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.