We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose Slides for Java - Unable to format the chart title

Hi Aspose team,

When I am trying to run the same example from https://docs.aspose.com/slides/java/chart-formatting/#format-chart-entities, I am getting Exception in line

PortionEx chartTitle = chart.getChartTitle().getText().getParagraphs().get_Item(0).getPortions().get_Item(0);

Exception in thread “main” class com.aspose.slides.b.a.g: Index is less than 0 or more than or equal to the list count.

Parameter name: index

Actual value was 0.

com.aspose.slides.Collections.ArrayList.do(Unknown Source)

com.aspose.slides.Collections.ArrayList.get_Item(Unknown Source)

com.aspose.slides.ParagraphsEx.get_Item(Unknown Source)

com.TestFormattingChartEntities.main(TestFormattingChartEntities.java:33)

at com.aspose.slides.Collections.ArrayList.do(Unknown Source)

at com.aspose.slides.Collections.ArrayList.get_Item(Unknown Source)

at com.aspose.slides.ParagraphsEx.get_Item(Unknown Source)

at com.TestFormattingChartEntities.main(TestFormattingChartEntities.java:33)

I am using aspose.slides-3.0.0.jar for Java 6. Could please advice what is the solution.

Thanks,

Sravanthi

Hi Sravanthi,

Thank you for sharing the details.

As you are using a very old version of Aspose.Slides, I would suggest you to download and try the latest version of Aspose.Slides for Java v8.6.0. If you still face any issue with the latest version, please share your template file with us to test the issue. We will check it and get back to you.

Thanks & Regards,

Hi,


Thanks for your reply.

Can I use the same license that I have for the latest version.

Thanks,
Sravanthi

Hi Sravanthi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Well, you can use a version of Aspose.Slides with your license which is released before the expiry of your license subscription (which you can check by opening your license file in a text editor e.g. Notepad). However, you can download and try the latest version (as evaluation) to make sure if your reported issue is working fine with the latest version or not.

Thanks & Regards,

Hi Owais,


Thank you for your reply. I am looking for a version which is older than 25-6-2013, in the download page I could see the oldest being available is Aspose Slides for Java 7.5.0, which is released on 26-6-2013. Could you please point me to an older version which is older than 25-6-2013.

Thanks,
Sravanthi

Hi Sravanthi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Please check the reply in the following post share by my colleague regarding your inquiry. Please feel free to contact support in case you need any further assistance.

https://forum.aspose.com/t/64310

Thanks & Regards,