We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Aspose.Slides for Reporting Services 5.2.1

I recently upgraded my Dev and Test SSRS servers from Aspsoe.Slides for Reporting Services 5.1.3 to Aspose.Slides for Reporting Services 5.2.0. I uninstalled 5.1.3 first before installing 5.2.0.

During testing, a bug was found. Aspose has now released version 5.2.1 which is suppose to resolve the issue(s). When I went to download 5.2.1, I noticed it says it is a "Hot Fix." Does that mean I must have 5.2.0 installed first, and then apply 5.2.1?

Or, should I uninstall 5.2.0 and then install 5.2.1?

In my pre-prod and Prod environments, where I still have 5.1.3 installed, what is the best procedure for upgrading to 5.2.1?

Please advise.

Thank you,

Tom Pettijohn

Hi Tom,


Thank you for posting.

I have observed your comments and like to share with you that you can upgrade to Aspose.Slides for Reporting Services 5.2.1 as you upgraded from Aspose.Slides for Reporting Services 5.1.3 to 5.2.0. Hotfix is like any other version and it is shared if some issue is a show stopper and very critical one, those issues are resolved in Hotfix version of the product instead of making our customers to wait for longer time.

I hope this will clarify the concept. Please share if I may help you further in this regard.

Best Regards,

Thank you for the reply.

It appears that I can install 5.2.1 over the top of 5.2.0 OR if no previous version is installed, go straight to 5.2.1 without having to install 5.2.0 first.

Hi Tom,


You can install Aspose.Slides for Reporting Services 5.2.1 after uninstalling Aspose.Slides for Reporting Services 5.2.0 and you are right, you can directly install Aspose.Slides for Reporting Services 5.2.1 without installing any previous version.

I hope this will clarify the concept. Please share if I may help you further in this regard.

Best Regards,