Free Support Forum - aspose.com

aspose.Slides is giving an error

Hello,

I am using Aspose.Slides to convert ppt decks to jpg images. Im using jdk 1.5.08. The slide converter worked fine so far. However today I tried to convert a ppt deck and the converter would only convert first 11 slides out of the 25. On the 12th slide it gives the following msg and stops:

"Color parameter outside of expected range: Alpha"

This error message is not part of my java code but it coming from elsewhere. When I take the slide #12 out of the deck then the conversion works.

Could someone please tell me what could be causing this error.

Thanks

Salman

When I get to the following section of code then the error occurs.

BufferedImage myImage = null;

myImage = mySlide.getThumbnail(dimension); <<<-this line causes the issue.

ImageIO.write(myImage, "jpg", aFile);

Hello Salman,

It looks like a bug in the Aspose.Slides.
Could you send me this presentation for testing please.

I uploaded the file to this link:

http://www.uploading.com/files/N4I2XH4P/123.ppt.html

Thanks

Salman

Salman,

This bug has been fixed.
Please check our new 1.6.12 hot fix.

Hello Alexey,

Thanks for such a prompt resolution to this issue. I really appreciate your help. One of the best technical support experiences I've ever had.

Cheers,

Salman