Aspose software's IVS encoding format problem

We are now using Aspose software to convert Word documents to PDF files in our systems. We have noticed that when using Aspose software to output PDF files, the software is unable to correctly read characters in the IVS encoding format.
The IVS encoding format is a combination of the U+ code of encoded Chinese characters and variant selection symbols, which is used to define and identify variant characters of encoded Chinese characters, allowing unencoded variant characters to be associated with the encoded Chinese characters and encoded within the ISO/IEC 10646 system, while preserving the glyph of the variant characters. Find more IVS/UVS information please go to the website: cmap - Character To Glyph Index Mapping Table (OpenType 1.9.1) - Typography | Microsoft Learn

@songweili
Please attach an example of a pdf document with this encoding, which is not displayed properly by the library.

Below is our case study, you can see Chinese characters in the file, they are followed by square spaces, this may be due to the unique character encoding of IVS. Another file is shown the encoding of the example word.

Testingdata information.pdf (13.1 KB)

Testingdata.pdf (42.6 KB)

@songweili
If I understand you correctly, you have converted a Word document to a PDF document. In PDF documents obtained in this way, when opening them in Acrobat, do you see squares instead of some symbols?

You are right; I didn’t explain clearly. When we converted the document to a PDF and opened it with Acrobat or other software, a square appeared. This square is not replacing any specific symbol. It’s because we tried to output an IVS character. IVS characters have two parts in their encoding (for example, U+36C7 E0101), whereas ordinary characters usually have just one part (like U+36C7). We believe the software treats the “E0101” part as a separate symbol, which causes the display issue.

@songweili
You have worked with the Aspose.Words product and I will move your question to the appropriate section of the forum.

@songweili Could you please provide the original Word document here for testing?

Testingdata.docx (12.9 KB)

sorry for late reply, the original Word document is uploaded.
@vyacheslav.deryushev

@songweili Please try to use following code before saving the document:

doc.LayoutOptions.TextShaperFactory = HarfBuzzTextShaperFactory.Instance;