Aspose.Word for Java 1.4.2


#1

I'm currently evaluating the Aspose.Word component for Java and have a question concerning the java environment version.

My customer has an existing 1.4.2-environment. For various reasons this environment will not be updated in a while. Therefore I would like to use the Aspose.Word-component using 1.4.2 (which the site states should be possible). However, when I try to build my code using 1.4.2 I get an error saying that Document-class has wrong version (49 should be 48, classic compiler version mismatch, that is). So, the question is, do I need to obtain a 1.4.2 version/does a 1.4.2-version exists, or do I have to look for another component to integrate with MS Word?

Regards

HÃ¥kan


#2

The error states that you using jdk1.5-compiled jar under jdk 1.4. You need to download Aspose.Words for Java 1.0.1 that supports both 1.4 and 1.5 (http://www.aspose.com/Downloads/Aspose.Words/Java/1.0.1.0/Default.aspx) and use Aspose.Words.jdk14.jar to build under JDK 1.4.x. Regards,