Aspose.Words conversion : a bug?


I’m facing a weird behaviour using Aspose.Words to convert a rtf file to pdf.

In the att. zip, in the pdf file, look in the margin of the gray block, entitled “renseignements” in the first page, you’ll see some thin red vertical dashes.

These dashes are not there in the source rtf file (also in the att. zip file).

How this can be explained please ?

Thanks in advance.
Nico F.

Hi Nico,

Thanks for your inquiry. I have tested the scenario and have managed to reproduce the same issue at my side. For the sake of correction, I have logged this problem in our issue tracking system as WORDSNET-12503. I have linked this forum thread to the same issue and you will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

Hi Nico,

Please use Document.AcceptAllRevisions method to workaround this issue. Hope this helps you.

Document doc = new Document(MyDir + "S0001STM000000.rtf");
doc.Save(MyDir + "Out.pdf");

Great, it fixes the problem.

Is it possible to know what’s going on ? does the rtf file is corrupted, obsolete ?

Thanks in advance.
Nico F.

Hi Nico,

Thanks for your inquiry. Our product team will analyze this issue. After the analysis of this issue, we will be in position to share the reason of this issue with you.

Please let us know if you have any more queries.

Hi Nico,

Thanks for your patience. It is to inform you that our product team has completed the work on this issue (WORDSNET-12503) and has come to a conclusion that this issue and the undesired behavior you’re observing is actually not a bug in Aspose.Words. So, we have closed this issue as ‘Not a Bug’.

There are two options to remove these vertical bars:

  1. Use RevisionOptions.ShowRevisionBars = false. This will hide revision bars.
  2. Use Document.AcceptAllRevisions. This will remove all revisions on the document and thus bars will not be displayed.