We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Asposeexcelwriter

Hi,


I am in the process of upgrading our web server from windows 2003 to windows 2012. We are using ASPOSEEXCELWRITER version 1.0.1753.27098 and it works in windows 2003 but in 2012 i am getting iis 500 errors. The pages using the software was developed using asp.net 1.1
Your help is greatly appreciated on this matter.

Hi,


Thanks for your query.

Well, I am not entirely certain about which Aspose.Cells component you are using? Could you elaborate and give me its version number here. It seems you had developed your solution using some older Aspose.Cells.Dll (compiled on .NET 1.x) version. For your information, we do not provide or support .NET1.x compiled version of the product any more, please see the document on which .NET compiled versions of the product we do provide now when you install our latest version of Aspose.Cells for .NET (i.e., v8.7.1) for your reference:
http://www.aspose.com/docs/display/cellsnet/Using+Aspose.Cells+on+32-bit+and+64-bit+Platforms

Furthermore, if you want to stick with your older version of the product, please try to use .NET 2.0 compiled version (you may get it from net2.0 folder at your installation directory) when you upgrade from Windows 2003 to Windows 2012 with your upgraded .NET framework versions (e.g 2.0, 3.x, 4.x etc.) for your underlying project.

Let us know if you still have any confusion or issue.

Thank you.

Hi,


Thanks for the quick reply.

We are using two aspose dll(s) in our production servers.

Aspose.Excel.dll Version 2.2.4.4
AsposeExcelWriter.dll Version 1.0.1733.27098


As i said, we have .net 1.1 application running in windows 2003. But we are in the process of upgrading the server to windows 2012. I’m wondering whether you have the same dll(s) compatible with windows 2012.

Hi,

Thanks for your posting and considering Aspose.Cells.

Aspose.Excel is very old version. It is obsolete and no more supported. We also do not now support .NET 1.1. The minimum .NET framework version supported is 2.0. We are afraid, you will have to upgrade your application and use the latest version.

You might encounter some issues while upgrading, but you can always take the help of this forum. Once, you will upgrade your application, then next time it will be very easy to upgrade because we are now maintaining all Public API Changes of every new Aspose.Cells release. Please check the following links for your reference.

( http://www.aspose.com/docs/display/cellsnet/Migrating+from+Earlier+Versions+of+Aspose.Cells )
( http://www.aspose.com/docs/display/cellsnet/Public+API+Changes+in+Aspose.Cells+8.7.1 )