We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Automation server can't create object

Hi, we have Aspose.Words 4.0 run great since 2006 but when we rebuilt/restored the server, Aspose.Words does not work anymore.

We’re getting an error message 2146827859::Automation server can’t create object

Can anyone help, please?

Thanks

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. Have you tried using a newer version of Aspose.Words? Also, it would be great if you provide full stack trace of the error and sample code where Aspose.Words throws an exception. I will check the issue on my side and provide you more information.

Best regards,

It is classic asp and the code worked fine before and has not changed

Here is the particular code:



var licObj = Server.CreateObject(“Aspose.Words.License”);

licObj.SetLicense(“Aspose.Words.lic”);

licObj = null;



again this code worked fine before. It is jscript in classic asp.

We do not want to upgrade if possible as the app was working perfectly before upgraded and downgraded.



There is no stack trace in classic asp.

Thanks

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. Have you tried reregistering Aspose.Words.dll? I think this should help you to resolve the problem. Please follow the link to learn how to register dll:

http://www.aspose.com/documentation/.net-components/aspose.words-for-.net/use-aspose-words-for-net-via-com-interop.html

Hope this helps.

Best regards,

Hi, we did try to register the Aspose.Words.dll. We un-register the dll, un-install aspose.word, clean up registry, re-install aspose.words, register dll again, reboot, etc. We tried everything.

Thanks

Hi there,

Thanks for your inquiry.

I think this may be an issue to do with browser security. Please do a quick Google of the error name for details.

Thanks,