We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Avoid Unwanted Duplex Printing of Word Document on RICOH IM c3000 Printer | C# .NET Printer Settings

I have a site using aspose that are having an issue when printing from all of their templates -
when they are printing on a RICOH IM c3000 printer, the results are printing duplex, even when the printer properties are set to not do so.

when they print on a different printer, they are not having the issue.

based on Printer settings are ignored,
I created a test application to see if the settings were being ignored. That program is printing properly.

the Aspose version in question is 19.12
attached are the default printer settings.
Test application shows it’s working correctly outside of Aspose.
default printer settings.png (41.0 KB)

need some help with this.

@conniem,

We suggest you to please upgrade to the latest (20.7) version of Aspose.Words for .NET and see how it goes on your end? In case the problem still remains, please ZIP and upload a sample Word document causing this problem here for testing. Also, create and provide a couple of following standalone simple console applications (source code without compilation errors)

  • Application that uses Aspose.Words code for printing and is producing undesired results (do not include Aspose.Words DLL files in it to reduce the file size).
  • Printing test application that does not use Aspose.Words’ code and is producing proper results.

Please also provide/mention any other necessary resources or required steps to be able to reproduce the exact issue on our end. We will then investigate the scenario on our end and provide you more information.

I do not have an Aspose based test application that generates the output, yet. Not familiar with C#, so it’s taking a bit.

however:

attached is a template(quicktest.dot) that I ran through my application with uses Aspose 20.07.
the file it generated is in output.zip. NOTE : when printed from word, it prints normally.

it only fails when printed to RICOH printer (it prints duplex). other duplex printers DO NOT have the issue.

also attached is the application that prints directly to the printer (duplext text), bypassing aspose. The print from that test application is fine.

the code that my dll uses to make the aspose call is:

    public void PrintOut(string Printer)
    {
        if (Printer.ToLower().Contains("googlecloud"))
            PrintToGoogle();
        else
        {
            m_DocumentPrint = new Aspose.Words.Rendering.AsposeWordsPrintDocument(m_AsposeDocument);
            m_DocumentPrint.DocumentName = Path.GetFileName(m_AsposeDocument.FieldOptions.FileName);
            m_DocumentPrint.PrinterSettings.PrinterName = Printer;
            m_DocumentPrint.Print();
        }
    }

quickTest.zip (7.0 KB)
output.zip (8.5 KB)
DuplexTest.zip (5.8 KB)

@conniem,

We have logged this problem in our issue tracking system. Your ticket number is WORDSNET-20870. We will further look into the details of this problem and will keep you updated on the status of the linked issue.

@conniem,

Regarding WORDSNET-20870, it seems that the problem occurs because of the specifics of that particular printer and/or its driver software. Aspose.Words’ code just prepares the graphical representation of pages and for printing it just uses the standard .NET System.Drawing.Printing.PrintDocument class and its PrinterSettings property, and Aspose.Words does not in any way control the duplex in its code. So, we suggest to specify the simplex printing directly through the settings like in the following sample:

AsposeWordsPrintDocument printDocument = new AsposeWordsPrintDocument(doc);
printDocument.PrinterSettings.Duplex = Duplex.Simplex;

In case you have further inquiries or may need any help in this regard, please let us know.

would this effect other customers that want duplex printing?

@conniem,

As this problem seems specific to a RICOH IM c3000 printer, users who are using this printer may be getting similar problem. But, they can specify the simplex printing directly using following code:

AsposeWordsPrintDocument printDocument = new AsposeWordsPrintDocument(doc);
printDocument.PrinterSettings.Duplex = Duplex.Simplex;

@conniem,

Regarding WORDSNET-20870, we have completed the work on this issue and concluded to close this issue with “not a bug” status. Please see my previous posts for details. In case you may have further inquiries or may need any help in future, please let us know by creating a new thread in Aspose.Words forum.