We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Blank table in output (CTS-3239)

Hi,


While converting attached MPP to PDF, the table doesn’t get render, output has blank table.

Rajiv
Hi Rajiv,

Thank you for sharing your concern with us.

I was able to reproduce this issue at my end using the latest version of Aspose.Tasks for Java 7.0.0 and have logged it as TASKS-33763 in our issue tracking system for further investigation by our development team. Once there is any information available in this regard, I'll update you here via this thread.

We are sorry for the inconvenience caused to you.

Hi Kashif,


I still see bad output with 7.2.

Input file has a blank table in right panel (I guess because ‘Work’ column has 0 hrs for all tasks), but PDF is populating some bogus ‘8h’ value in the table out of nowhere.

Please reopen the same bug, we cannot close TASKS-33763 as fixed like this.

Thanks,
Rajiv

Hi Rajiv,


I have tested the scenario and observed the “8h” values in the table. This ticket is re-opened and I will write back here as soon as some feedback is available in this regard.

We are sorry for any inconvenience caused to you.

Hi Kashif,


Thanks for the confirmation and reopening the bug.

I am not sure how was the bug-verification passed by your QA
team, this was the basic use-case which they must have tested, and anybody who
just glances at the input & output can see this obvious issue.

Actually we are seeing same thing happening for number of cases nowadays that the bug gets marked as fixed with inadequately / poorly implemented fix by your Dev team followed by very poor testing / verification done by your QA team.

Net result is that we wait for the fix to arrive in new release for about a month, and it goes in vain after seeing the poor fix quality which is practically not usable for enterprise customers, we’re scared to even let customer know that the bug is fixed in the interim period.

It seems there are process related issues with Aspose, and we want to escalate it, particularly the lapses on your QA team part (that way non-fixed bugs goes all the way and make to the release) is highly concerning / alarming.

I would encourage you to consolidate and prepare list of all reopened bugs in recent past from us and other clients, and escalate it with the QA head. Please convey that the customers are very dissatisfied by the poor testing done, and would want to see immediate corrective action being taken such that non-fixed / poorly fixed bugs do not make to the release.

Thanks,
Rajiv

<o:p></o:p>

Hi Rajiv,


I am sorry for any inconvenience caused to you.

The ticket TASKS-33763 was logged in order to handle the situation where there are no resources at all in the project, hence,resulting in empty Resource usage table. After this specific case was handled as enhancement in the latest version, this new bug was identified. Tests were incorporated earlier to handle the bug of blank resource usage table, however, this additional check was missed somehow. I have raised this issue with the higher ups and QA team as well who have acknowledged this missing test, and will be more careful in future in this regard.

This “8h” issue is a new bug in the already implemented feature and is communicated to the development team. We have already fixed it now and I am in contact with them for consideration of the hotfix for this issue.

Please spare us little time for further discussions and I will write back here immediately as soon as some feedback is available.

Hi Rajiv,


We have resolved the issue of rendering false value “8h” in the resource usage table. Could you please download the latest release Aspose.Tasks for Java 7.2.1, test the issue at your end and let us know the feedback?

Thanks Kashif for taking it up with the QA team.


And yes, I verified it with 7.2.1, the issue has got fixed. Thanks for the quick turnaround.

Regards,
Rajiv

Hi Rajiv,


We are glad to know that your issue is resolved and thank you for providing the feedback.

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan