Bookmark inserted table squeezed from 17.8


We recently updated Asposer Words from 15.4 to the latest 23.6. We found a issue with one scenario where we insert html table into bookmark. The table was exported just file until 15.4. After upgrading to 23.x we found the table is squeezed.

I tested other previous Aspose versions and figured it’s broken from 17.8.
We could tweak the template to avoid the issue however, we have a lot of templates in production environments and reviewing all of them will be very time consuming job for us.

I am attaching the sample code that reproduce the bug scenario. (46.7 KB)

Just for more information, template file looks like this

Where red highlighted, there’s a bookmark configured

Until 17.7 the result looks like below

From 17.8, the result looks like this

We have opened the following new ticket(s) in our internal issue tracking system and will deliver their fixes according to the terms mentioned in Free Support Policies.

Issue ID(s): WORDSNET-26203

You can obtain Paid Support Services if you need support on a priority basis, along with the direct access to our Paid Support management team.

Hi Alexey,

Would you be able to provide us some update regarding this bug? Last 2 bugs I raised, it was reviewed relatively quickly and decided whether they are bugs or not. However, this time, the status for the issue seems to be staying at “New” stage for a while. If you need any more information regarding the issue, please let me know.


@sentientsoft Unfortunately, there is no updates regarding this issue yet. The issue is currently in the queue for analysis. Once analysis is done we will be able to provide you more information. Please accept our apologies for your inconvenience.

is there any update?

@fangjian Unfortunately, there are no news yet. The issue is still in the queue for analysis.

Hi Alexey,

It would be great if you could provide us some update. The ticket has been at “New” status for quite some time. I believe the sample code is detail enough to explain the problem. Please let us know if you need more information.


@sentientsoft Unfortunately, there are still no news. Please accept our apologies for your inconvenience. I have asked the responsible developer to take a look at the issue shortly.

Hi Alexey,

Could you provide us some update? I see the initial investigation is done for this ticket.


@sentientsoft Yes, we have completed analysis. The incorrect behavior is caused by fix for WORDSNET-15558. The code improperly handles the particular case in your document. We will rework the fix and let you know once the issue is resolved.

Thanks for the update Alexey,

If you can give us any indication of which next version of aspose will have the new fix, that would be great.


@sentientsoft Unfortunately, the issue is not yet scheduled for development so currently there is no estimate. We will be sure to keep you updated and let you know once the issue is resolved.

Hi Alexey,

Can I have the schedule for this bug fix please so that we can schedule fix in our product as well?
This bug stops us upgrading to the latest Aspose library at the moment.


@sentientsoft I am afraid, the issue is still not scheduled for development. So there are no estimates at the moment. Please accept our apologies for your inconvenience.

Hi Alexey,

I can see the ticket is now in “Closed” status.
Could you give us an update? Will it be fixed? if this is going to be fixed, when will it be?


@sentientsoft The issue is already resolved in the current codebase. The fix will be included into the next 24.2 version (February 2024). We will keep you updated and let you know once the version is published.

The issues you have found earlier (filed as WORDSNET-26203) have been fixed in this Aspose.Words for .NET 24.2 update also available on NuGet.