Free Support Forum - aspose.com

Bookmark issues

Hi,

I have a couple of issues copying bookmarks from a template document to an output document.

1. The last bookmark in the template does not get copied. I found a post here with the workaround of saving the file to disk before looking up the Bookmarks and it worked fine. Is this still an open issue with Aspose because saving the file to disk might be an overhead going forward. Please note here that I am using a licensed copy of Aspose.Total, so chances of the output doc getting truncated and the bookmark missing due to that can be ruled out.

2. I have around 8-9 bookmarks in my template doc. But in the output doc only some of them are getting copied, not all. Unfortunately, I have not been able to find a pattern of skips to help you diagnose this issue. So please let me know if there is anything you need from me to understand the problem better.

Regards,

-rfc

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. Could you please attach sample documents and provide me code snippets that will allow me to reproduce these issues. I will investigate these problems and try to help you.

Best regards.

Hi Alexey,

Please find attached the template file and the sample code for your reference.

I have put in in-line comments in the code for better understanding.

Let me know if you need anything else.

Regards,

- rfc!

Hi<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for additional information. Unfortunately I can’t reproduce the issue. Could you please simplify your code? I tried just open/save your document and it seems that all works fine. Maybe you can create a simple application that will demonstrate the problem.

Also make sure that you are using the latest version of Aspose.Words.

Best regards.