We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Border lines in the header area of the table are not visible

Border lines in the header area of ​​the table are not visible when the document is displayed after it is loaded into the system. An error was received after upgrading to “Aspose word 19.9”.

YG9985.zip (155.2 KB)

@srmbimser

Please note that Aspose.Words mimics the behavior of MS Word. If you convert your document to PDF using MS Word, you will get the same output.

In Aspose 19.6, the document is converted to pdf without error. We started to get this error in 19.9. Because we have so many documents in this way, we can’t offer our customers to edit them.

@srmbimser

We have logged this problem in our issue tracking system as WORDSNET-19373. You will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

@srmbimser

Thanks for your patience. It is to inform you that the issue which you are facing is actually not a bug in Aspose.Words. So, it will be closed as ‘Not a Bug’.

This is well known problem with viewing PDF files containing thin lines. Thin lines may disappear at different zoom levels. The thin line display issue can occur with PDF files created from any vendor. This is because the appearance of table lines is affected by the limited resolution of the display monitor.

Output in PDF viewer may vary due to screen resolution, windows scaling, enabled options, viewer itself.

You can check this behavior by converting document to PDF using MS Word. It has same artifacts on different zoom levels.

When converting from MS Word to pdf, the table limit is not lost. Table border disappears when viewed in pdf format with Aspose. The problem is that it is not faded, but does not occur at all.
YG9985.zip (628.4 KB)

@srmbimser

Please check the screenshot of msw.pdf. The table’s border line is not visible.

Unfortunately, we cannot do anything in layout to improve document appearance in different PDF viewers because layout is already correct. We recommend some workarounds that will work on any computer:

  • Make table borders thicker.
  • Or add some space between nested shape and thin table borders.

You may also consider changing Adobe Acrobat Reader’s default behavior to enhance the display of thin lines on the display monitor. This behavior can be changed by going to Edit, Preferences, Page Display, then check/uncheck ‘Enhance Thin Lines’. Please note that you need to restart the Adobe after applying this change.

Which version of MS Word reputation do you use? With MS Word, you can display the border of the table in the file saved with a PDF extension in a lighter color than other borders.

@srmbimser

You can check this issue by generating PDF using MS Word 2016 and 2019. As shared in my previous post, it is well known problem with viewing PDF files containing thin lines. These thin lines may disappear at different zoom levels. Please check the workaround of this issue shared in my previous post.