We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Brocken shapes in the copied worksheet

<!–[if gte mso 10]> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

<![endif]–>

Hi Aspose team,

I’d like to submit an issue which I’ve encounter recently. Namely issue is occurs when I making a copy of one worksheet to another. As soon as the workbook is saved shapes (arrows) became to look a little bit different as well as the labels on it (see attached screenshots).

In the attachment you can find the original Excel file I’m using in my application and the simple program example. This program does three things: open, copy and then save.

I’m using Aspose.Cells v 7.0.1 library, Office 2010 32-bit on Windows 7 64-bit.

Any help шы highly appreciated.

Thank you in advance.

Hi,


I have tested your issue using your template file with my simplest code, I can notice the issue regarding shapes in the copied worksheets.

Sample code:
string path1 = @“e:\test2\tosend\BrockenLogo.xlsx”;
string path2 = @“e:\test2\tosend\outBook2.xlsx”;
Workbook dataTemplate = new Workbook(path1);
Workbook textTemplate = new Workbook();
textTemplate.Worksheets.Clear();
int i=0;
//copy all sheets
foreach (Worksheet worksheet in dataTemplate.Worksheets)
{

//create new worksheet in texttemplate
Worksheet newWorksheet = textTemplate.Worksheets.Add(“Sheet” + i.ToString());
newWorksheet.Copy(worksheet);
i++;

}

textTemplate.Save(path2, SaveFormat.Xlsx);

I have logged a ticket for the issue with an id: CELLSNET-30787. We will look into your issue to figure it out soon.

Thank you.

Thank you for the quick response.
Will looking forward to get the fix.
Thank you in advance.

Hi, .

We have fixed this issue. Please download: Aspose.Cells for .NET v7.0.1.6

Hi Aspose team,

Thank you the the update. It works. Awesome.
Will look forward for further cooperation.
Thank you,
Andrew.

The issues you have found earlier (filed as 30787) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.