Free Support Forum - aspose.com

Build Error

We been using Aspose.Cells for a while and has worked fine in every program until now. Including it in this new project causes a build error.

Error 1 Could not load file or assembly 'file:///...\Bin\net2.0\Aspose.Cells.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515) C:\...\SGEN

I suspect it conflicts with the web reference that project uses since removing the web references allows the project to build (well, after commenting all the code that uses the web service). Anyway, is there a way to get Aspose.Cells to work with projects that have a web service reference in it?

By the way, I did try the latest version and got the same build error.

Thanks,
Scott

Hi,

If there is already Aspose.Cells assembly in a GAC, then please remove it.

After adding a reference to Aspose.Cells component in Visual Studio while creating a Web
Service
, set “True” for “Copy Local”
property, it will work fine and the Aspose.Cells.dll file will be available in
the “\bin” folder.

e.g

  • Select Aspose.Cells in References node in Solution Explorer.
  • Set True for “Copy Local” in Properties window.

If it does not solve your problem, then let me know.

It was set to 'Copy Local'.

However, I got it to work. One I the suggestions I found when I googled the error was to make sure the dll wasn't blocked (open file properties and click unblock). However, the file wouldn't stay unblocked. I have no idea why. Anyway, I tried the other suggestions I found but nothing worked so I tried the new Aspose.Cells 6.0 and posting here.

While waiting for a response it occured to me to try unblocking the new Aspose.Cell dll. The file stayed unblocked and that allowed the project to build.

So I guess the problem was some wierd security thing on my computer that wouldn't let me unblock the dll. Even though the new dll will unblock, I probbably should try to figure out why the other one wouldn't.

Well, thanks,
Scott