We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Cannot find Aspose.Slides.ReportingServices Error

I am trying to load Aspose Slides into Visual Studios 2013

I get the error

Could not load file or assembly ‘Aspose.Slides.ReportingServices, Version=17.8.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56’ or one of its dependencies. Failed to grant minimum permission requests. (Exception from HRESULT:0x80131417). Required permission cannot be acquired.

In the report previewer.

Thanks
Tom Fussell
Senior Software Engineer

@james.fussell,

I have observed the information shared by you and request you to please launch Visual Studio using Administrator privileges and then try solution on your end. If there is still an issue then please provide the sample project reproducing issue on your end.

I have tried the administrative approach. The project is simply a blank report. I wanted to see if the slides would show up in the drop down menu on the report preview.

I have placed the ASpose.Slides.ReportingServices.dll in the private assemblies folder and updated the
RSPreviewPolicy.config and the RSREportDesigner.config as instructed.

I then created a blank report project in VS 2013 and the error appears when I go to the Report Preview.

Thanks
Tom

I also installed the .NET MSI thinking that might help but no luck.

tried to install Aspose.slides for .net from NuGet packages. It said it only worked with .NET framework 4.0 and lower. We are currently using 4.5. Could this be the issue?

@james.fussell,

I have observed your following comments:

Can you please share if you are using Aspose.Slides for Reporting Services assembly on your end? It appears from your above comments that you are probably using Aspose.Slides for .NET assembly in your application. Have you downloaded the latest assembly from this download section link. If not then please try the shared download link.

I did use Aspose Slides for Reporting Services. When it did not work I though maybe I needed the .NET version as well since I was using Visual Studios. It did not help and I have since uninstalled it.

Thanks

@james.fussell

I request you to please share the VS 2013 project that you have tried using on your end. I am assuming that you have also tried the guidelines shared in this documentation article as well.

So is that instead of using the config changes in Visual Studios. The error shows after setting up the config files as stated in the documentation.

@james.fussell,

Thank you for sharing the information. As requested earlier, please share the sample project, environment details, Operating system details, SQL Server an reporting services details used on your end. Our product team shall investigate the issue on their end to help you further. I am also assuming that using Administrator privileges is still not working on your end and you have tried those.

Not sure how to share the project. It truly is very very simple however. I use
Visual Studios 2013
Windows 7
.NET 4.5
SQL 2014

I create a test project for SSRS in Visual Studios called test1. I create a blank Report, I put no objects on the report it is entirely blank and not attached to any SQL server. I then click the Report Preview tab and the error comes up as described in the first post on this chain.

All I want to see is the list of Aspose.Slide options in the export menu of Report Preview. Then I can start fully testing your product, but I cannot even get to that stage of the process.

I have full administrative privileges on my laptop.
I have placed the dll for Aspose.Slides in the appropriate folder ~/PrivateAssemblies and altered the RSReportDesigner.Config and the RSPreviewPolicy.Config in the same folder as described in your support documents.

Additionally, I have tried Aspose.Slides version 17.8 and 17.9

And just FYI. My boss is very excited about your product. It could potentially solve many issues for us, if we can get it to work.

@james.fussell,

We appreciate your growing interest in API and really wish to help you out. I have discussed this with our product team and suggest you to please run Visual Studio using “Run as Administrator” by right clicking on Visual Studio exe. If the attempt will be unsuccessful, then please share the sample project reproducing the issue on your end for investigation. You can zip sample project and share us here by uploading that. If zip size is more than 5 MB, then you can upload on any FTP server and share the download link with us.

test1.zip (6.0 KB)

Running as administrator gives same error

RSReportDesigner.zip (2.9 KB)

here are the two config files I am using

using Aspose.Slides version 1.8 Universal

@james.fussell,

Thank you for sharing the information. An issue with ID SLIDESRS-33545 has been added as investigation on our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be fixed.

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan