Free Support Forum - aspose.com

Can't load any PostScript files :-(

Hello,
It’s been almost a month. Are there any news?

@markjordan

Thanks for your inquiry.

We are pleased to share with you that your issue has been resolved and its fix will be included in Aspose.PDF for .NET 18.8, which will be released in next month. We will surely inform you further, when this version of the API is released.

Wonderful. Thank you very much.

Hello Asad. I understand that version 18.8 has just come out and is available for trial download? Was the problem solved in this version?

@markjordan

We are pleased to inform you that earlier logged issue PDFNET-44892 has been resolved in latest version Aspose.PDF for .NET 18.8. However, latest version is not yet available over NuGet for download and expected to be available in current week. As soon as it is available publicly, we will let you know.

@asad.ali

In checking the release notes for Aspose.PDF for .NET 18.8 and I don’t see PDFNET-44892 on the list, was it not included or is this a typo/missed in the notes?

1 Like

@doug.ludlow

Fix to your issue (filed as PDFNET-44892) was planned to be included in Aspose.PDF for .NET 18.8 but I am afraid to share that issue required more time to get resolved. At the moment, issue resolution has been postponed for future version(s) of the API. As soon as we have some reliable ETA to share, we will let you know. We are sorry for the inconvenience caused.

Sad to hear that you haven’t resolved the issue yet.
By trial and error I managed to deduce that if I add the following line at the beginning of the PS file, Aspose manages to read it:
@PJL ENTER LANGUAGE=POSTSCRIPT

However, the output file I get is a blank PDF with the Aspose watermark on it. Is this happening because of the trial version? Am I missing something? Or is this another bug?

@markjordan

Thanks for contacting support.

We are pleased to inform you that your issue has been resolved in Aspose.PDF for .NET 18.9 which will be available for download in next week. We will surely notify you once the release is available for download over NuGet Gallery.

Please make sure to use valid license before using Aspose.PDF for .NET or consider applying 30-days temporary license to evaluate API without any limitation. In case issue still persists, please let us know.

I applied for a 30 day license and tried again. After manually adding the line
@PJL ENTER LANGUAGE=POSTSCRIPT
to the beginning of the PS file, I ran the conversion and get a blank page again.

I’m really trying to make this work because there are few products like yours, but it looks like it simply doesn’t function. Can you give me any advice to resolve this?

@markjordan

You were unable to get correct output because the fix was not available in the API version which you are using.

As shared earlier, the fix to your issue has been included in the upcoming version which is not available for download yet. Aspose.PDF for .NET 18.9 would be available for download in current week and we will let you know once it is released. We greatly appreciate your patience in this regard. We are sorry for the inconvenience.

The issues you have found earlier (filed as PDFNET-44892) have been fixed in Aspose.PDF for .NET 18.9.

I just tried version 18.9.1 with a valid 30 day license.
The issue that you call 44892 (your library freezing when opening a PS document that doesn’t begin with “@PJL ENTER LANGUAGE=POSTSCRIPT”) was NOT resolved.
The other issue, where I add the prefix myself, convert the document and get a blank document - wasn’t resolved either.
Basically, You’ve been pulling my chain for 3 months, while the bottom line is that your product simply does not do what it says it does.
I will not be testing Aspose.PDF any longer. Thanks for your help.

@markjordan

We are sorry for any inconvenience which has been faced. Please note that we have tested the scenario in our environment using both 18.9 and 18.9.1 versions of Aspose.PDF for .NET API and were unable to notice any issue. For your kind reference, following is sample code snippet and input/output documents.

string inFile = dataDir + "input2.ps";
string outFile = dataDir + "PDFNET_44892_out_18.9.pdf";
Document doc = new Document(inFile, new PsLoadOptions() { FontsFolders = new[] { "C:\\Windows\\Fonts" } });
doc.Save(outFile); 

PDFNET_44892_out_18.9.pdf (2.9 KB)
input2.zip (6.3 KB)

You may please check that source PS file is same which you had shared with us earlier. Please feel free to let us know if you see any issue in the shared output.

This is the exact issue I’m experiencing here: PostScript to PDF conversion hangs or produces a blanks document and I can confirm that the issue is still not resolved in Aspose.Pdf v18.9.1, the PDF produced is blank…

@doug.ludlow

Thanks for contacting support.

Please note that sometimes issues are related to specific source documents and resolved for those documents only. The issue referenced by you is related to different input PS files than the file shared in this thread. Would you please try converting PS file shared in this thread into PDF using Aspose.PDF for .NET 18.9.1. In case you notice any issue, please feel free to let us know.

When I attempt to download the input file shared in the thread, I get the following message: “Sorry, this file is private. Only visible to topic owner and staff members.”

@doug.ludlow

Please download the file using this link.

Hi Asad.
I just thought I’d share that issue 44892 has NOT been resolved in 18.9, nor in 18.11 which I am now testing.

@idokalir

We have responded your relative query in other thread. You may please share your response there.