Can't remove the very first indent when inserting bullets


#1

Hi,

I insert a bulleted list into a table. Default behaviour - same as in word - is one indent followed by the bullet. In word I can remove that first indent, but with Aspose.Word I can’t manage it. Is there a way to remove the first indent, or to explicitly set the first bullet on the very beginning of the cell?

Thanks in advance

PS: I’m using Aspose.Word 2.2.5.0

Michael Mann


#2

Hi Michael,

Try to play with the DocumentBuilder.ParagraphFormat.LeftIndent property before inserting a list. See here for more information:

http://www.aspose.com/forums/ShowPost.aspx?PostID=8778


#3

Hi,

thanks for that “hint”…That’s what I’ve been playing around with all the time:

builder.ParagraphFormat.LeftIndent and builder.ListFormat.ListLevelNumber.
But nothing seems to get it done. Setting these properties to 0 is the closest thing, but not really what I want. There is still “one” indent…Setting LeftIndent to a value less than 0, the bullets disappear, meaning they move to the left, where I can’t see them.

So any other proposals, or isn’t there a way to solve that ?

Michael


#4

Unfortunately, it seems to be the only way to achieve that goal at the moment. We will possibly improve list formatting features some time later.


#5

Hi,

I think nothing has been achieved yet. For my understanding, the behaviour of the mentioned properties is not quite correct. The first indent, let’s say the value ‘0’ for LeftIndent should be the very first beginning of the line, cell, table or whatever.

In Word, the default bullet is placed at the first indent - but you CAN decrease (outdent) that default behaviour to place the bullet at the very beginning - and that should be the value ‘0’ of the LeftIndent property! Or shouldn’t it?

Michael


#6

I'm agree, it would probably be more correct. We're already working in this area and will add more features (including fix of the LeftIndent behaviour I guess) in the next 1-2 months.

Thank you for the request.


#7

Hi again,

thanks for your understanding. But this kind of formatting is critical to my application. Is there a way to get that fixed sooner? Hotfix, or something like that? We are about to go live in two weeks, and I would appreciate it very much, if we would have that problem solved.

Thanks again!


#8

Okay, please wait a little, we'll see what we can do for you and reply to you in some hours is it possible to fix this problem much sooner.


#9

Michael,

We will certainly notify you about the fix to this issue within 1-2 weeks, but we can’t promise it will be fixed in this time interval due to some development difficulties related to changing list formatting. Thank you for patience.


#10

Hi,

any updates on this thread?

Michael


#11

Hi Michael,

We are very sorry. This problem cannot be fixed quickly. We are working on it, but no significant progress yet.

Thank you.


#12

Hi again,

anything happened in the last 4 weeks?

Cheers,
Michael


#13

Hi Michael,

There are no changes on list formatting yet. We apologise for that. We hope that you understand us - it’s impossible to just implement this feature without making significant changes to whole list formatting, and this is not the easiest process.


#14

Hi,

any updates on this thread? By now, it’s the end of may and it’s inconceivable that there wasn’t the time to make a “significant” change ??

I would appreciate any input

Michael


#15

As a matter of fact we are still working on this “big refactoring”. It does not just involve the list indent issue, it basically involves improvement for the way all formatting attributes are handled inside Aspose.Word.

Some parts of the work were already made public - for example PageSetup.TextColumns. Soon, we will expose things like Styles, list formatting, detailed cell and table formatting, custom tab stops and so on.

Sorry it took longer than expected, but it will be done.


#16

To anyone with similar problems. I've overcome this using a custom bullet style in Word. You can customise the indent of a bulleted list (hint use -0.63 to get it flushed to the left margin, since bullets always flush .63 by default). There's a number of settings for the "Outline Numbered" List you can customise such as Number position > Left > Outlined at (-0.63); "Text position" > "Tab space after" (0). Then the 2nd level "Outlined At" (0); "Tab space after" (0.63). I've used a square and a dash here so ur not limited to numbers.

Then from the styles menu, right click the style highlighted for the list, modify and give it a sensible name. Use this for the

CurrentParagraph.ParagraphFormat.StyleName

Along with

ListFormat.ListLevelNumber

To change the indent level