We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Cell format is lost/content is missing after saving a specific document with Aspose.Cells

Dear Aspose Team,

We obtained an error report for our product, and it turned out that the error comes from saving a specific excel file with Aspose.Cells. We have license for the 19.xx version of Aspose, but we tried with the latest Version(=20.4.0.0) too and we obtained the same result. We tried to minimize the excel data as much as possible to help You locate/fix the problem. In the following attachment (link: ImpExpData.zip (35.4 KB)
) there are 3 files:

  • the “testExcelFile.xls” file is the file what we try to save
  • the “SavedFile1.xlsx” file is just an .xlsx file saved from the previous one
  • the “finalResult.xls” file is the resulted oucome (the result should look like the first “testExcelFile.xls” one)

What we do with Aspose.Cells is: if the file is .xls we need to save it as .xlsx, “we do our stuff” and after that we need to save the file back with the original format in this case .xls. We paste a minimal code below, which results the mentioned problem:

Workbook wb = new Workbook(pathToTestExcelFile);
wb.Save(pathToSaveFileName1File, SaveFormat.Xlsx);
Workbook wb1 = new Workbook(pathToSaveFileName1File);
wb1.Save(pathToFinalResultFile, SaveFormat.Excel97To2003);

We are waiting for Your findings/answer.

With best regards,
Bordi Tamas

[BUG-3297]

@tbordi,
We were able to observe the issue but we need to look into it more. We have logged the issue in our database for investigation and for a fix. Once, we will have some news for you, we will update you in this topic.

This issue has been logged as

CELLSNET-47339 - Cell format is lost/content is missing after saving

@tbordi,
This is to inform you that we have fixed your issue (logged earlier as “CELLSNET-47339”) now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

1 Like

@tbordi,
Please try our latest version/fix: Aspose.Cells for .NET v20.4.6 (attached)

Your issue should be fixed in it.

Let us know your feedback.

Aspose.Cells20.4.6 For .NetStandard20.Zip (5.3 MB)
Aspose.Cells20.4.6 For .Net2_AuthenticodeSigned.Zip (5.3 MB)
Aspose.Cells20.4.6 For .Net4.0.Zip (5.4 MB)

The issues you have found earlier (filed as CELLSNET-47339) have been fixed in Aspose.Cells for .NET v20.5. This message was posted using Bugs notification tool by Amjad_Sahi

1 Like

We checked and it is indeed fixed. Thanks for the effort :smiley:

@ tbordi,

You are welcome and good to know that your issue is resolved. Feel free to contact us if you have further comments or questions.