We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Cells merge with aspose.cells 5.3 and 6 performance

Hi,

I have migrated from aspose cells 4.7 to 5.3 and 6 and I have some performance problems when I have a lot of cells to merge in the latest version.

I create a test project for AsposeCells 4.7, 5.3 and 6.0.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I attach an
zip file with a solution with these 3 libraries and 3 projects.:<o:p></o:p>

-
TestingAsposeMergeMethod
– use Aspose.Cell 6.0<o:p></o:p>

-
TestingAsposeMergeMethod53
– use Aspose.Cell 5.3<o:p></o:p>

-
TestingAsposeMergeMethodOld47
– use Aspose.Cell 4.7<o:p></o:p>

The performance result
is very clear – version 5.7 and 6.0 are at least 100 times
slower than 4.7

<?xml:namespace prefix = v ns = “urn:schemas-microsoft-com:vml” /><v:shapetype id="_x0000_t75" stroked=“f” filled=“f” path=“m@4@5l@4@11@9@11@9@5xe” o:preferrelative=“t” o:spt=“75” coordsize=“21600,21600”>
<v:stroke joinstyle=“miter”>
<v:formulas>
<v:f eqn=“if lineDrawn pixelLineWidth 0”>
<v:f eqn=“sum @0 1 0”>
<v:f eqn=“sum 0 0 @1”>
<v:f eqn=“prod @2 1 2”>
<v:f eqn=“prod @3 21600 pixelWidth”>
<v:f eqn=“prod @3 21600 pixelHeight”>
<v:f eqn=“sum @0 0 1”>
<v:f eqn=“prod @6 1 2”>
<v:f eqn=“prod @7 21600 pixelWidth”>
<v:f eqn=“sum @8 21600 0”>
<v:f eqn=“prod @7 21600 pixelHeight”>
<v:f eqn=“sum @10 21600 0”>
</v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:formulas>
<v:path o:connecttype=“rect” gradientshapeok=“t” o:extrusionok=“f”>
<o:lock aspectratio=“t” v:ext=“edit”>
</o:lock></v:path></v:stroke></v:shapetype>
You will find also a picture where you see my test result named result.jpg

Hi,

Thanks for your interest in Aspose and your sample project files to measure performance.

We will investigate this issue and update you asap.

Hi,


I have tested the issue using your sample code/project with v6.0.0.4 and found the issue, it takes time a bit to perform the task as you mentioned by your screen shot. We will investigate the issue. I have logged a ticket for it with an id: CELLSNET-29132.

Thank you.

Hi,

After analyzing your issue further, if the merged cells intersects other merged cells in the file, MS Excel will throw a message box when opening the file. So, we added checking in the new versions. If there are many merged cells, it will work slowly consequently. We will add a new method Cells. Merge(int firstRow, int firstColumn, int totalRows, int totalColumns, bool checkConflict, bool mergeConflict) for your need. If the checkConflict parameter is false, we will not check conflicts, so it will process fast. We will provide a fix within 1-2 days.

Thank you for your quick response.

I hope receive quickly a fix because it’s a real problem for me.
Thanks

Hi,

Please try this new fix. We have added a new method. Please download: Aspose.Cells for .NET v6.0.0.5.

After my first tests, it works fine now.

thanks for your quick fix

Hi, I don’t see this issue in the release note of version 6.0.1.

Can you confirm that this issue is fixed in this version ?

Hi,

Thanks for your asking this question.

I can confirm that your issue has been fixed in this version Aspose.Cells for .NET v6.0.1.