We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Certain characters disappear when converting a pdf file to multipage tif images

We are using and have a license for aspose pdf .net to convert pdf files to multipage tif images. Is there any setting in the aspose .net api that could be used to prevent the swedish characters Å,Ä and Ö from disappearing when converting a pdf file to a multipage tif?
Code used to convert
Document pdfDoc = new Document(@“C:\Temp\TillSkanningen.pdf”) Aspose version used is 21.9.0 the latest available on nuget.

        Aspose.Pdf.Devices.Resolution resolution = new Aspose.Pdf.Devices.Resolution(300);
        Aspose.Pdf.Devices.TiffSettings settings = new Aspose.Pdf.Devices.TiffSettings();
        settings.Compression = Aspose.Pdf.Devices.CompressionType.CCITT4;
        settings.Depth = Aspose.Pdf.Devices.ColorDepth.Format1bpp;
        
        Aspose.Pdf.Devices.TiffDevice device = new Aspose.Pdf.Devices.TiffDevice(resolution, settings);

       
  
        device.Process(pdfDoc, @"C:\Temp\OutputTiff.tif");

@nojdddan

Can you please share the source file and generated PDF with snapshot of issue. We will be able to investigate that on our end on provision of requested information.

TillSkanningen.pdf (255.6 KB)
Here is the original pdf file used to convert to multipage tiff image.
OutputTiff.zip (64.0 KB)
And the tiff image where you can see that some characters is missing. Not all the swedish special characters have gone missing but most of them

@nojdddan

This looks like a problem related to missing fonts. I request you to install related fonts in your system and share your feedback.

Hi I have another pdf file which results in the same result when converting to a multipage tif I looked at the fonts in the pdf document where Helvetica,Helvetica Bold, ArialMT ArialMT-Bold. Installed all the above mentioned fonts on the computer I am running the code on but the result is still the same. Is there somewhere in the code where I need to add these fonts? Or is there some other font not mentioned in the document itself that might be missing?210906SKA5136215.pdf (101.4 KB)

@nojdddan

A ticket with ID PDFNET-50695 has been created in our issue tracking system to further investigate the issue on our end. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

is there anyway to see if the ticket PDFNET-50695 is investigated or waiting in queue to be investigated?

@nojdddan

You can see its status at the bottom of this page. There is no other way to track the issue progress.

Please note that it was recently logged in free support model and will be investigated and resolved on a first come first serve basis. We will surely inform you as soon as we make some definite progress towards its resolution. Please be patient and spare us some time.