We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Chart rendered as if "Show Default Axis" is enabled

Hello! When using SheetRender to export range containing chart to image, the chart is exported as if “Axes - Secondary Horizontal Axis - Show Default Axis” option is enabled although it is not. Please, check the attached console project and screenshots!

Thank you.

Hi,


I think you are using MS Excel 2010 to view the template file’s chart. If you could open your template file into MS Excel 2007, you will see that the output image (generated by Aspose.Cells APIs) is matching to the chart.

Let us know if you still find the discrepancies.

Thank you.

Hi! Thank you for your response!
I opened the file with Excel 2007 also and I can see it looks exactly like in Excel 2010. So, this is definitely an Aspose rendering bug. Please, see the attached screenshot!

Thank you.

Hi,


Here is my Excel 2007 screen shot taken when opened your file into it.

Thank you.

Hi!
You are using an outdated version of Office 2007. The screenshot I posted is taken in Excel 2007 SP 2. Please try with SP 2 or SP 3! Also, please see how is looks in Excel 2003 in the attached image! I think you should be using the latest versions of the products when you decide whether you are dealing with a bug or not. So, keeping in mind that Excel 2003, Excel 2007 SP2 and Excel 2010 render the chart with obvious differences from the way Aspose renders it, I definitely say it’s an Aspose bug. The chart should be rendered as close as possible to how it looks in the latest version of the latest product (Excel 2010 SP 1).

Thank you.

Hi,


After further evaluation of your issue and opening the file into MS Excel 2010 and other versions, I can find the issue. I have logged a ticket with an id: CELLSNET-40928. Our concerned developer will soon look into it to figure it out.

Thank you.

Hello,

We’ve tested again with Aspose.Cells version 8.0.2.0, and it seems the problem is fixed. Can you confirm ?

Thank you,
Mihai Andrei
Senior Software Engineer
IBM Romania

Hi,


I checked the status of the ticket “CELLSNET-40928” into out database, it is not set to resolved/ closed, so we cannot confirm. Anyways, if v8.0.2.x works well for your needs, you are good to use it.

Thank you.