We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Chart sometimes does not appear based on legend position

Hi. I’ve noticed there is a problem when trying to convert excel chart to svg. Problem occurs when legend is drag & dropped from default bottom position. I’m sending you code written in .net core together with simple xlsx example that can be found in examples folder. Also, in outputs folder you can find svg files rendered using aspose.cells library. I’ve used latest version of aspose.cells 21.7.0. Notice word document with the steps how to reproduce this issue. AsposeBug.zip (111.0 KB)
Steps to reproduce.docx (225.1 KB)

@ottap,

The issue is also reproduced in common .NET Framework versions. I able to reproduce your mentioned issue using your template file. The chart is not rendered its chart area/plot area fine, it is empty. The chart in Excel sheet does not appear based on legend position we customized. If we use “example_override.xlsx” file it works fine while using “example.xlsx” file, it does not work fine. I have logged a ticket with an id “CELLSNET-48509” for your issue. We will look into it soon.

Once we have an update on it, we will let you know.

1 Like

@ottap,

This is to inform you that your issue is resolved now. We will provide you the fixed version within the next few days after performing QA and incorporating other enhancements and fixes.

1 Like

The issues you have found earlier (filed as CELLSNET-48509) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao

Unfortunately, same problem occurs. I tried using a new excel example. I was using aspose.cells version you provided in the link and also using directly new nuget package that was provided for version 21.8.

@ottap,

Could you please share your new Excel file and sample code to reproduce the issue, we will check it soon.

I’m sharing with you screenshot of excel chart and svg output. You can see that the whole chart is missing. Also, I’m sharing code. It is the same code shared with you previously but I added a new xlsx example in examples folder named example_new.xlsx

AsposeBug_v2.zip (119.8 KB)
excel_chart.png (1.6 KB)
aspose_output.png (18.1 KB)

@ottap,
Thank you for sharing sample data. We have observed the issue and logged it with the ticket.

1 Like

@ottap,
Please try our latest version/fix:
Aspose.Cells21.8.1 For .Net2_AuthenticodeSigned.Zip (5.6 MB)
Aspose.Cells21.8.1 For .Net4.0.Zip (5.6 MB)
Aspose.Cells21.8.1 For .NetStandard20.Zip (5.6 MB)

Hi @Eric.wang,

I confirm that the bug is resolved with this patch. Thank you!

@ottap,

Thanks for your feedback.
Good to know that your issue is resolved by the new fix. In the event of further queries or issue, feel free to write us back.

The issues you have found earlier (filed as CELLSNETCORE-137) have been fixed in this update . This message was posted using Bugs notification tool by simon.zhao