We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Cloning slide using PresentationEx

Hi,

I use tempPresentation.CloneSlide for cloning PPT presentation where tempPresentation is source This works perfect for PPT formats.

Now there is a need to clone a PPTX presentation. So I tried using the following

Option 1:

SlidesEx slidesEx = presentation.Slides;
slidesEx.AddClone(tempPresentation.Slides[0]);

Option 2:


SlidesEx slidesEx = presentation.Slides;
slidesEx.InsertClone(slidePosition, tempPresentation.Slides[0]);

where presentation is PresentationEx object and is the destination presentation, tempPresentation is PresentationEx object and is the source presentation. But for both the options I get the error as

The node to be removed is not a child of this node

I am using Aspose.Slides (Version 4.0.1.0).

Please suggest me the way to clone PPTX.

Hi Htanmo,


You are using a fairly old version of product. Please use the latest available version of Aspose.Slides for .NET 5.7.0. Please visit this documentation link for more information about slide cloning. Please share, if I may help you further in this regard.

Many Thanks,

Hi Mudassir,

1.I am getting the sample cloning as in the Aspose web site done with slide in destination being removed. This was done with same 4.0.1.0 Even that is not happening in my application even though the code seems to be correct. For reference I have added the code snippet in previous thread.

Please look on it and tell me for correct changes in code.

2. Also I tried using trial version dll of 5.7.0 with license of 4.0.1.0. Buth I get some error as "Updates not allowed...." Please tell me how to proceed with 5.7 usage.

Hi,

I have created a sample project using Aspose.Slides for .NET 5.7.0 that clones slides from one presentation to another using both methods mentioned by you with no error. Please use this for your kind reference. Secondly, if you are unable to use Aspose.Slides for .NET 5.7.0 then you may please upgrade your subscription. Please visit this link for renewal of subscription.

Many Thanks,

The issue was with old dll. I used new version 5.7 after removing the old license file which gives me expected cloning with watermark.

Thanks Mudassir.

I just now saw ur attachement. Will see it shortly. Thanks for ur effort.