We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Color of Content Control lost after save

Hi

I create a simple Word document with MS Word. Insert a content control, set color, save and reopen in Word, all is fine. The color of content control is still set.

After I open these file with aspose word and save, the color of content control is lost.

Thanks and best regards

Stephan

Hi Stephan,

Thanks for your inquiry. I have tested the scenario using latest version of Aspose.Words for .NET 14.3.0 with attached in.docx file and have not found the shared issue.

In case you are using an older version of Aspose.Words, I would suggest you please upgrade to the latest version (v14.3.0) from here and let us know how it goes on your side.

If the problem still remains, please attach your input Word document here for testing. I will investigate the issue on my side and provide you more information.

Please look in my solution VS2012. There you can find an document with Content controls. If you run the solution, a copy of this document with aspose is created and Color of all controls is lost. I have run this solution with aspose.word Version 13.12 and 14.2. Both generate the same result.

Thanks, Stephan

Hi Stephan,

Thanks for your inquiry. I have converted the shared input document to output Docx and have not found any issue with color of content controls. I have checked this issue in MS Word 2010 and 2013. I have attached the output Docx with this post for your kind reference.

Could you please share some more detail about the color of contents controls? It would be great if you please share the screenshots of input and output document.

Hi Tahir

Pleace look shared screenshots (in & out). I have the same result.

What do you mean with converted my document? My shared document is in native Office 15 Format.

Thanks
Stephan

Hi Stephan,

Thanks for sharing the detail. I have tested the scenario and have managed to reproduce the same issue at my side. For the sake of correction, I have logged this problem in our issue tracking system as WORDSNET-10072. I have linked this forum thread to the same issue and you will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.