We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

COM Interop

Hi there,


two days ago I bought Aspose.Words for .NET and I’m still trying to get it up and running from within VB6. I can use Intellisense in VB6, all methods and properties are exposed correctly but the moment I try to access one of the objects I get the error message “ActiveX component can’t create object”, Error number 429.

I also tried to install Aspose.Words on another machine (32Bit Windows)…same result…I tried late binding as well as early binding, always with the same result.

Even when I try to use VBscript as it is specified in the Aspose.Words help-file I get the same error:

This is my test-code, the error occurs when CreateObject is run:
Dim helper
Set helper = CreateObject(“Aspose.Words.ComHelper
Dim doc
Set doc = helper.Open(“c:\temp\xx.doc”)

Please help

Best regards
Michael
Hi Michael,

Thanks for your inquiry. Please make sure that you have registered Aspose.Words for .NET with COM Interop. I suggest you please read following documentation article for your kind reference.
http://www.aspose.com/docs/display/wordsnet/Use+Aspose.Words+for+.NET+via+COM+Interop

Hope this helps you. Please let us know if you have any more queries.

Hi!


Thank you very much, the problem is solved, I accidentally used the 64bit-version of regasm.exe

Best regards,
Michael

Hi Michael,


Thanks for your feedback. Please feel free to ask if you have any question about Aspose.Words, we will be happy to help you.