We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Compilation error in VS2010 SSRS 2008 local processing

Good day

I used the aspose reporting service control in VS 2008 and SSRS 2005 .NET 3.5sp1 and it worked fine. We deploy the project to the client pc and run the report in local processing mode (about 15 pc’s working on a local server in one location).

When we upgraded the project to VS 2010 and SSRS 2008 and .NET 4.0 full version (not client) the report would not compile. I changed the dll to the one in the SSRS 2008 folder, but no luck. I even tried the dll provided in this post:
http://www.aspose.com/community/forums/2/288701/aspose.barcode-ssrs-configuration/showthread.aspx

Any help please

Attached a screen dump of report settings and error withing VS 2010.

Kind regards
Christo

Hi Christo,

Thank you for inquiry.

I was able to reproduce the issue with VS 2010 .NET 4.0 project at my end. However, it works as expected when I create the project with .NET 3.5. I have logged this issue (ID: 28855). We will look into it and will inform you when it gets fixed.

Good day Saqib Razzaq

Thank you for the quick reply. One usually waits weeks for replies! I’m glad you were able to reproduce the problem and found the faulty link in the chain.

Looking forward to a solution, because, like any control, it is crucial to the project :wink:

Kind regards
Christo

Good day Saqib Razzaq

Is there anywhere I can track the progress of this issue by using the issue ID?

Kind regards

Hi Christo,

Please try the following steps:

1. Download and install the latest version of Aspose.BarCode for SSRS.

2. Locate your install directory of VS2010 (You can find the path by checking the shortcut's properties in the "Target" setting, it's usually looks like "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe")

3. Copy the Aspose.BarCode.ReportingServices.dll to "x:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies\" folder.

Good day Dean Deng

This seems to resolve the problem! Thank you very much!

Kind regards
Christo