We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Compile time error when using Aspose Words in C++/CLI project

Hi,

We have just tried to upgrade to Aspose.Words V21.7 but we are having a compile issue when using the dll in a C++CLI application. I have been able to reproduce this in a new C++/CLI project that can be found here: https://1drv.ms/u/s!Ao-n6dBju-a32iU8GbrVVOaF8tOY?e=aHgQf7

Error:C2365 
'Aspose::Words::CompositeNode::': redefinition; previous definition was 'property'

It looks like this might be a obfuscation issue, as below:
https://stackoverflow.com/questions/9501825/redefinition-error-c2365-in-c-cli-caused-by-babel-obfuscator

Thanks, Zoe

1 Like

@zoe.w

We have tested the scenario and managed to reproduce the same issue at our side. For the sake of correction, we have logged this problem in our issue tracking system as WORDSCPP-1116. You will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

2 Likes

Hi. Just wondering if there is any update on this? We can’t upgrade our version until it is resolved.
Thanks, Zoe

@zoe.w

Currently, your issue is pending for analysis and is in the queue. Once we complete the analysis of your issue, we will then be able to provide you an estimate.

Just checking again if there is any update on this? We can’t use the product until this is resolved.
Thanks, Zoe

@zoe.w

Unfortunately, the analysis of your issue has not been completed. We will be sure to inform you via this forum thread once there is an update available on it.

Hi.

Apologies for contacting you again but this is an urgent issue for us - we cannot use the product until this issue is resolved.

I have tried the most recent release today and this is still present. Is there any update or estimate of when this might be looked at?

Thanks, Zoe

@zoe.w

We regret to share with you that there is no update available on this issue at the moment. This issue is still under analysis phase. We will be sure to inform you once there is any news available on it.

@tahir.manzoor - any update on this? We can keep using the old version of the DLL which worked fine for a while, but it’s not great for our security policy to use out of date components.

Can your obfuscator use some kind of attribute or xml configuration to assign a fixed name to the property vs type to distinguish them?

@GMiddleton The issue is still unresolved. We will experiment with obfuscator options and let you know when the issue is resolved.

The issues you have found earlier (filed as WORDSNET-22660) have been fixed in this Aspose.Words for .NET 22.1 update also available on NuGet.

Thank-you for getting this fix out. I have tried it and it all looks fine.
Zoe