We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Conditional format rules corrupted when saving template as xlsx

Using version 8.5.0



If you unpack the attached zip-file to the folder C:Temp and execute the following 2 lines of code, you’ll notice that the Conditional formatting rules inside the table has changed:



Dim workbook As Aspose.Cells.Workbook = New Aspose.Cells.Workbook(“C:\temp\Conditional template.xltx”)

workbook.Save(“C:\Temp\Conditional.xlsx”, Aspose.Cells.SaveFormat.Xlsx)



On the template the 3 rules will apply either a red, yellow or green color but on the generated workbook, the rules has changed so that there now are 2 rules that applies a green background and one that applies a red background (see attached jpg file).



Regards,

Martin Moustgaard

Hi,


Thanks for the template file, sample code and screen shot.

After an initial test, I observed the issue as you mentioned. I found Conditional format rules (for the table) corrupted when saving template XLTX file as XLSX via Aspose.Cells APIs as per your screen shot:
e.g
Sample code:

Workbook workbook = new Aspose.Cells.Workbook(“e:\test2\Conditional template.xltx”);
workbook.Save(“e:\test2\out1.xlsx”, Aspose.Cells.SaveFormat.Xlsx);

I have logged a ticket with an id “CELLSNET-43760” for your issue. We will look into it soon.

Once we have any update on it, we will let you know here.

Thank you.

Hi,


Thanks for using Aspose.Cells.

We are pleased to inform you that your issue is
fixed now. We will provide you the fixed version after performing QA and
incorporating other enhancements and fixes. Hopefully, we will share
the fixed version here in the next few days.

Keep in touch.

Hi,


Please try our latest version/fix: Aspose.Cells for .NET v8.5.0.3 (attached).

We have fixed your issue now.

Let us know your feedback.

Thank you.

Hi Amjad.

This does indeed solve my problem regarding conditional formatting rules becoming corrupt.

Thank you for the quick update.

Regards,
Martin

Hi,


Thanks for your feedback.

Good to know that your issue is sorted out by the new fix. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon.

Thank you.

The issues you have found earlier (filed as CELLSNET-43760) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.