Free Support Forum - aspose.com

Configuring old version for Aspose.Slides for Reporting Services (SSRS)

I’ve used aspose slides for ssrs in my previous firm, just purchased the latest for my new firm. I’ve noticed the same issues with the latest version using SQL 2016 with charts and text not export properly. I noticed using an older version worked in my previous firm, specifically the product version 2014.10.15 and file version 5.2.0.0. Do you still have the .dll available for this version? The current export to Powerpoint is totally broken for me.

@djung527,

I have observed your requirements and like to share that as per policy the versions released in past one year from current date are allowed for downloading. I have uploaded the requested version on following link and request you to please notify me when you download so that I may remove the access.

Thank you. Will this require a new license file? Seems like the export function disappeared.

@djung527,

You will only require the license file if the already one that you have expiry date before release date of Aspose.Slides for Reporting Services 5.2. You may try using API with license and if you will observe watermark then it means your license in not valid for product.

Hello - thank you the response and apologies for the delay. after I saved the older version of the dll to the directory and double checked all the config on the config file, the apose export function is no longer there. I had done the exact same thing in my last organization and worked without a hitch, restarted and everything. would you be able to help? I’ve attached some pdf and png for reference. Thank you!

aspose file location.PNG (34.5 KB)
Configuration.pdf (116.0 KB)

@djung527,

You may please need to follow the guidelines shared over this documentation link to install and configure Aspose.Slides for Reporting Services manually on your end.

Thank you. I have followed the instructions down to the t. Do you happen to have the msi installer for version Aspose.Slides.ReportingServices_5.2.0.zip?

@djung527,

I suggest you to please visit this download link for your kind reference to downloading the MSI installer.

Thank you. Tried it and it won’t install probably because the OS is too new.
One of the problems I have is that the aspose powerpoint export is way off from what is rendered on screen or if I was to export to the builtin PDF or word. After it is exported to powerpoint and when trying to open the file, I get this error (attached).pptError.PNG (3.8 KB)

Is this a known issue? Should I be engaging in paid support to remedy this?
Thank you

@djung527,

Can you please share which version of Aspose.Slides for Reporting Services you are presently using on your end as you have stated that 5.2.0 is not installed properly.

I request you to please provide the generated presentation file with us that is throwing this error.

Secondly, before sharing with us, I suggest you to please try using latest Aspose.Slides for Reporting Services 20.5 on your end. In case there is still an issue in generated presentation then please share the source RDL file with dataset. RPL export file and generated presentation throwing Repair error. We will be able to investigate the issue further on our end on provision of requested information.

Hello – I tried both 5.2.0 and 20.5. The former which I manually installed. When doing a manual installation, I do not get the option to aspose export option after the report renders. I have carefully followed the instructions and edited the config files. This is something that I have done in my previous job many times so I am familiar with the process.

When using version 20.5 using the msi install, the option to export does show, however opening the ppt or pptx gives me this error:
pptError.PNG (3.8 KB)

After selecting Repair, the file opens but does not look anything close to what is rendered on screen.

Because of sensitive information, I won’t be able to provide the actual files but here are some screenshots in the attachment below of what it looks like on the browser vs. when I export into WORD vs. ASPOSE Slides.
I had to redact sensitive information. Is there a way we can get on a call for this?
Aspose_Issues.pdf (153.8 KB)

Thank you
DJ

@djung527,

I like to share that we really wish to help you and we will provide based on the latest version to date. If the latest version is reproducing the issue, we are here to help you further. In order to proceed further, we need to at-least RPL export file and generated presentation throwing Repair error. I have made this thread private and now only you and Aspsoe staff has access to it. You can also share the information privately with us using Private Message option to. For that you need to click on my name Icon in any of my post and press Message button. A new window will popup, where you can share the information privately with us. You need to notify us here in this thread that you have shared the information privately so that we may access that and help you further.

Unfortunately, without provision of requested information, we may not be able to proceed further to resolve the issue.

I cannot even send you the rpl file, I reinstalled everything. I get the aspose slide extensions but no rpl.
I’m attaching the windows events log that shows you it cannot load.

I’m using Windows server 2016 and SQL Server 2016 DEV.rplcannotload.PNG (21.0 KB)

I also have paid support with the ticket #174457 but I am not getting any response.
I think we need to figure out why the rpl extension won’t load.

Thank you

@djung527,

We are sorry for your inconvenience. First of all you must check if Aspose.ReportingServices.Debug.Rpl.dll is placed in working directory (*for example …\Reporting Services\ReportServer\bin*). Then please check PublicKeyBlob in rssrvpolicy.config. We suspect that Aspose.ReportingServices.Debug.Rpl.dll is not installed.