We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Convert PDF in IBM JDK coredump

We are experiencing coredump problems when using your Aspose library for pdf conversion in the aix environment and need your help to resolve them as they are currently associated with the production environment.

Environment:

JDK(use IBM WebSphere jdk):

java version “1.8.0_241”
Java™ SE Runtime Environment (build 8.0.6.5 - pxa6480sr6fp5-20200111_02(SR6 FP5))

@hanmaoren

Could you please share the complete detail of your issue along with sample input PDF and code example to reproduce the same issue at our end? We will then provide you more information on it.

Dear Tahir,

see the attachment:

nfs-software-5.7z (6.1 KB)

@hanmaoren

Your query is related to Aspose.Words. So, we are moving this forum thread to Aspose.Words’ forum where you will be guided appropriately.

Thanks, how can i found the reply with Aspose.Words, also in this post?

@hanmaoren,

Could you please clarify the nature of the problem and provide additional information about the OS version you are using and the testing methodology. After that, we will investigate the issue and let you know about it in this forum thread.

Problem: Use Aspose Library to convert rpt files to pdf, process coredump
Test method: java command/webpshere application call

ENV:
OS: AIX 7.2 、Windows Server 2019 Standard
JDK: websphere jdk

@hanmaoren Unfortunately, it is still not clear what the problem is and how to reproduce it. I have checked the conversion of the attached document on my side and PDF document is produced properly.
Could you please clarify whether exception is thrown on your side, when you perform conversion or the resulting PDF is generated improperly.

Dear Alexey,
which part need to be clear? in our side, we use openjdk or oracle jdk run the code,it is work normal, but if change to ibm jdk is just coredump.

@hanmaoren Could you please provide stack trace of the exception thrown on your side? Also, please specify what version of Aspose.Words you use.

nfs-software-5.7z (87.3 KB)
Dear Alexey,
see the attachment. it is the core dmp infomation. as the limit of upload size, I will upload core file with anther one.

core.20220507.153049.11403770.0001.part01.7z (4.0 MB)

core.20220507.153049.11403770.0001.part02.7z (3.4 MB)

@hanmaoren,

Thank you for providing additional information. We will continue to investigate this issue and let you know via this forum thread.

@hanmaoren,

Unfortunately, we were unable to reproduce this issue on our side. Converting the attached RTF document to PDF works fine both using oracle jdk and ibm jdk. Please check the functionality using the latest version of the Aspose.Words library (currently it is 22.5).

We use the Aspose.Words library version of 22.3 & 22.4, later we will try with 22.5. thanks!

Dear Alex,

We tried to do the same conversion using ibm jdk on a linux environment using 22.5 and still got the error, see screenshot for the error.
Is the way I run it different from yours?

@hanmaoren,

This issue has been logged as WORDSJAVA-2729. We will keep you posted and will let you know as soon as the issue is resolved. Please accept our apologies for the inconvenience.