Free Support Forum - aspose.com

Convert task to tiff images


#1

I am trying to save a task file to multi-page tiff image. I set the following :slight_smile:
ImageSaveOptions saveOptions = new ImageSaveOptions(SaveFileFormat.TIFF);
saveOptions.HorizontalResolution = 200;
saveOptions.VerticalResolution = 200;
saveOptions.MarkCriticalTasks = true;
saveOptions.LegendOnEachPage = false;
saveOptions.Gridlines = new List();

Gridline gridline = new Gridline();
gridline.GridlineType = GridlineType.GanttRow;
gridline.Color = Color.CornflowerBlue;
gridline.Pattern = LinePattern.Dashed;
saveOptions.Gridlines.Add(gridline);
saveOptions.FitContent = true;
saveOptions.PixelFormat = System.Drawing.Imaging.PixelFormat.Format16bppRgb565;
saveOptions.PresentationFormat = PresentationFormat.TaskSheet;
saveOptions.TiffCompression = TiffCompression.Lzw;
// Save project layout to separate files
saveOptions.SaveToSeparateFiles = true;
project.Save(dataDir + “PrintProjectPagesToSeparateFiles2_out.tif”, (SaveOptions)saveOptions);

The output tif contains several pages, but if last row number on page 1 and the first row number on page 2 you will see several missing rows. Also there columns are missing on the right side on every page.


#2

@elumicor

It is requested to kindly share the sample file with us for further investigation.

Moreover, You may share confidential files in a private message and the files shared in private message shall only be accessible to Aspose staff. For this purpose, please find the “Message” button by clicking on my name.


#3

@elumicor

We have investigated this issue and found that it is happening because of VerticalResolution. We tried by reducing it as follows and it worked fine.

saveOptions.VerticalResolution = 120;

Moreover, please feel free to write back to us if you need further assistance in this regard.


#4

I made the following change:
saveOptions.HorizontalResolution = 120;
saveOptions.VerticalResolution = 120;

now it shows all rows and I assume all columns.

This must be a bug. You should be able to set a Resolution of 300.


#5

@elumicor

Thank you for your feedback.

We have logged this issue with ID “TASKSNET-3022” for further investigation. You will automatically be informed here once we have more information to share.