Free Support Forum - aspose.com

Convert XPS to PDF in Linux using Aspose.Page for Java - an exception is thrown

Hi,

Have tried to convert XPS to PDF using Java, it is throwing an exception.

Please let me know it can be done by Java?

It can be using in linux machine?

Thanks,
John felix

@johnfelix

Thanks for your inquiry.

Aspose.XPS for Java API is offered to be used in Java Applications and you can also use it in Linux. However, the feature of XPS to PDF is regretfully not present in the API at the moment. Feature request has already been logged in our issue tracking system as XPSJAVA-10 for the sake of implementation. We will let you know know as soon as the feature is available. Please spare us little time.

Furthermore, you may use Aspose.PDF for Java in order to convert XPS to PDF and in case you face any issue, please feel free to let us know.

Hello,
We have lifetime license for Aspose Total since 2018. Within this licence we use Aspose-xps, which was updated in August 2019 to the version 19.4. From September 2019 Aspose xps licence seems to be not recognized and we cannot use it. It is critical for our system and this case is urgent for us and our clients. Please let us know how we can check the licence and related issue. We don’t have paid support as it expired in August 2019. Please let us know what you need to check our licence

@aleksandra.klamczynska

The product Aspose.XPS for Java has been discontinued and replaced with Aspose.Page for Java. Your existing license will work with new product for those releases which were released before the license subscription expiry date. You may please try using Aspose.Page for Java 19.7/19.8 with your license and in case you still face any issue, please feel free to let us know.

Guys,

we have a serious issue with XPS licence, which should should be active under our Aspose Total licence described below. Please let us know how we can activate Aspose XPS or Aspose pages - both of them were tried in versions before the last update date - 2019/08/10 - and they are not working.

We’ve purchased perpetual Aspose Total licence, which included Aspose XPS. This component is crucial in our software for some clients and we we have very unpleasant discussions with them. Our developer tried both solutions described by you and none of them is working.

@aleksandra.klamczynska

Could you please share your license file with us in a private message so that we can test it in our environment and address the issue accordingly. You may please send license in a private message by clicking over username and press Blue Message button.

@aleksandra.klamczynska

Thanks for sharing the license in private message.

We have tested it with Aspose.Page for Java 19.7 and did not notice any issue. We tested it with XPS to PDF conversion with one of our sample XPS documents and output PDF was fine. Your license file is compatible with Aspose.Page for Java 19.7 version as its expiry date is 2019/08/10.

Would you kindly share a bit more details i.e. screenshots of issue, exception message or stack trace, etc. with us so that we can further investigate the issue which you are facing.

Please also note that we set the license as following before testing the scenario:

com.aspose.page.License jlic = new com.aspose.page.License();
jlic.setLicense("D:\\Recent Working\\Aspose\\License\\testlic.lic");