Free Support Forum - aspose.com

Converted doc from word to pdf is a mess

Don't have any idea why this is coming out like this, but the attached word and pdf documents seem quite different. We are using the xml bind conversion w/ IsImagesInXmlDeleteNeeded set to true. The conversion code we're using is equivalent to the steps listed here

http://www.aspose.com/documentation/file-format-components/aspose.pdf-for-.net-and-java/converting-word-documents-to-pdf.html

Any ideas what's causing such problems?

versions used are

Aspose.PDF = 3.7.0.0

Aspose.Words = 4.4.3.0

Hello Todd,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for considering Aspose.

I have tested the scenario and tried converting your provided Word file into Pdf. In my case the Pdf is almost like the input word file beside the table border issue over 2nd page. I will discuss this issue with development team and soon will let you updated with the status. Please make sure you are using latest version of Aspose.Words & Aspose.Pdf. I am using Aspose.Words 5.2.1.0 and Aspose.Pdf 3.7.0.0. The resultant Pdf is in attachment, kindly take a review.

We have already mentioned that its very difficult to generate the Pdf file identical to Word file, but still we will try our level best to make it as similar as possible.

Hello Todd,

I have discussed the issue with development team and it has been logged into our defect management system as PDFNET-5573. We will investigate this issue in detail and will keep you updated on the status of a correction.

Hi Todd,

I have investigated more on the format issue. I found it is caused by an issue of Aspose.Words as there was some thing wrong in the intermediated xml which generated by Aspose.Words. I have reported it to aspose words team. They will reply you soon. Thanks.

Best regards.

Hello!<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for your inquiry. Issue with table borders is known and we’ll get back bo it soon. I’ll notify you on any progress.

Regards,

Thanks all for the awesome response time on this. Using the latest versions got us 99% of the way there - I look forward to new assemblies to get us to 100%.

Thanks again for your assistance.

Hello!<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

After some investigation I separated this case to the following issue:

#5662 – Borders are resolved incorrectly near vertically merged cells

As a workaround you can remove all table borders and nest a table with only one cell in every cell originally having borders. Applying borders to those tables doesn’t produce issues.

Regards,

Greetings-

Any news on when this bug might be released as part of a bug fix release? It's been just over a month and was looking for a quick update.

Thanks,

Todd

Hello!<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for your patience. #5662 is still unresolved. We’ll try to fix it faster but from my experience it is not easy. Sorry for inconvenience.

Have you tried any workarounds? If you can change source documents you probably can avoid this case.

Regards,

There will be no fix for this in the Aspose.Words + Aspose.Pdf conversion. Please use the Aspose.Words direct to PDF conversion method.