Free Support Forum - aspose.com

Converting RTF to PDF: API calls resulting in 400(bad request)

Hello,


We have been receiving 400(bad request) results from some of our API calls over the last two days.

We are experiencing these results with both GET and PUT requests.

Calls

PUT: https://api.aspose.com/v1.1/storage/file/

GET: https://api.aspose.com/v1.0/words/?format=Pdf

Have there been any performance issues lately? I can provide specific examples to look into via email if needed. Any help you can provide is most appreciated.

Is anyone available to take a look at this issue? We have a document that we have tried to convert multiple times but we keep receiving 400(bad request) results. Thank You

Hi Paul,

Normally HTTP error 400 means there was some issue with your request and it was not accepted by Aspose for Cloud. Can you please share some more details e.g.

  1. Do you see this error for specific documents or any document?
  2. If a request fails for a certain document, does it keep failing or passes when you send the same request again?
  3. Were same documents working for you in past and not working now?

Please also share your document and code for further investigation. We are sorry for the inconvenience.

As a side note, please always use https://api.aspose.com/v1.1 endpoint.

Best Regards,

Hello Muhammad


I sent you information directly on the api call we are trying to make.

We have tried the call multiple times and it is still resulting in a 400 error.

Is there anything you can see on your end. I would like to resolve this issue as soon as possible so we can get this document out to our client.

Hi Paul,

There seems to be some issue with the document and I get this exception at my end {"Message":"The document appears to be corrupted and cannot be loaded."}. MS Word was also not able to open this document so it looks to be the issue with the document.

Best Regards,