Free Support Forum - aspose.com

Converting Slide to Images randomly removes spaces from text using Aspose.Slides for Java

We are using Aspose.Slides for Java v18.7 to process PPT/PPTX and convert slides to images.

We load custom fonts (combined from Mac/Windows) into a custom directory and load on boot.

When we convert certain Powerpoints, some of the resulting images will have spaces removed from the text. When this occurs, there are NO font substitution warnings.

I have included two screenshots, the first is from the source file which shows the expected spacing for the text. The second screenshot shows the resulting image which shows a space removed. This happens on multiple slides.

Source Text (correct spacing) (9.0 KB)

Result (space removed) (10.1 KB)

@commercialtribe,

I have observed your requirements and suggest you to please visit this documentation link to see how to load fonts externally in application. If you still find issue then please share the source presentation, working sample code, Java details, Operating System details and generated output with us.

Please read the original comment as I stated that we are already loading a custom font directory. In addition, we have instrumenting the warning callbacks for font substitutions and are not seeing any font substitutions implying it is correctly picking up the font.

Here is an example.

aspose-sample.zip (6.9 MB)

Unzip it, and run make run.

It loads a test presentation and an external font directory containing fonts for that test presentation and converts 3 images from the presentation and outputs the files into a /output directory.

You will notice that spaces are removed from text in each of the slides when compared to the source presentation.

@commercialtribe,

I have worked with source files and sample project shared by you using Aspose.Slides for Java 18.7 and unable to observe any issue. Can you please share screenshot for presentation you shared in sample project pointing towards issue so that we may further investigate to help you out. Also please share complete environment details with us.Files.zip (124.9 KB)

Here are the images outputted from that presentation.

output.zip (126.6 KB)

We have tried on the following operating systems without success.

Mac OSX High Sierra v10.13.3
Ubuntu (multiple versions)

@commercialtribe,

I have observed your comments. A ticket with ID SLIDESJAVA-37322 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with issue so that you may be automatically notified once issue will be fixed.

Hi - has there been any update on this?

@commercialtribe,

I have verified from issue tracking system and regret to share that at present the issue is still unresolved as it has just recently been created. We request for your patience till the time the issue gets resolved.

Hi - as you previously mentioned almost a month ago you are still working towards getting this resolved.

I would like to check in and see if any updates have been made on this?

Omitted spaces seems like it would be a pretty important bug, and unfortunately is the sole blocking issue for us moving forward with purchasing this product for use.

Thanks and look forward to update.

@commercialtribe,

I have verified the issue status from our issue tracking system and like to share that it has been marked as resolved in upcoming Aspose.Slides for Java 18.10. We will share the good news with you as soon as the product will be available online by end of October 2018.

@mudassir.fayyaz This issue not solved in new version. I am using license version of aspose-slides-18.8 which is latest version but in this version also the spacing issue not resolved.
Can you please tell me how can I solve this issue?xyz.jpg (121.8 KB)
.

@Shree995,

The concerned issue has been marked as resolved in upcoming Aspose.Slides for Java 18.10 which will be availble by end of October 2018. We request for your patience till the time the product will be available online.

We are seeing this same issue. For us this seems like a regression as this is happening with Arial font too, which did not happen earlier.

Can you please confirm.

@rahul.contiq,

The concerned issue associated with this thread is going to be resolved in upcoming Aspose.Slides for Java 18.10. We will share the good news with you as soon as the product will be shared online.

Hi @mudassir.fayyaz
can you please tell me when Aspose.Slides for Java 18.10 will be available online to use?

@Shree995,

The concerned release is likely to be available online during next week. We will share the notification with you once release will be available online.

Hi @mudassir.fayyaz
Please tell me when the new updated version is available online. Now new month started this error affecting my project so please can you able to tell me when this release will be expected.

Thanks

@Shree995,

I have observed your comments. Can you please visit this link to download latest version. Please share feedback with us if there is still an issue.

@Adnan.Ahmad Thanks for quick response. I will check and let you know if I face any other issue in this new version.