Corrupt Data?


#1

I’m running into a problem that is a bit strange.

I’m using an HTML form to post an Excel file to the web server. Once the file is received, I’m use ASPose.Excel to read and manipulate the file.

I then offer the file back to the user in a link. Most of the time, I have no problems. However, I have this one particular file, and after it has been manipulated with ASPose.Excel, and I try to re-upload the file I just downloaded from the link, the web browser displays the message “Document Contains No Data”.

This happens despite the file being about 4.8 meg in file size, and Excel can open the file without any problems at all. I tried renaming the file, and making a copy of the file, but neither worked. If I copy the data from the Excel file into a new Excel file and save it with a new name, that does work, but it’s obviously not a practical solution.

Any idea what might be causing this? I’m sure it’s not the browser, b/c I get the same results in IE, Firefox, Netscape, etc…

The only manipulation I’m doing to the Excel file is highlighting a few fields in yellow, and adding some cell comments to certain fields.

Help!
-Steve


#2

Really a strange problem. Please zip and send me the file from your user and the created file. I will check what caused this problem. And please send me the detail error message in your web browser, thanks.