Corrupt Excel File


#1

Hi,

I am having a strange problem with Aspose.Excel. (I am using 3.5. I tried Aspose.Cells and it gives the same result.) I am using smart tags to populate several worksheets in a workbook. When I try to open the finished workbook in Excel, I get an error saying the file is corrupt and cannot be repaired. If I do them separately (saving each sheet in a separate workbook), I can open them without problems. Only when putting all sheets in a single file does the problem occur. Here is the strangest part: One of the data table used to populate a particular sheet has 2080 rows of data. If I add one more row to that data table, the problem goes away! I am sending both the corrupt 2080 rows file and the fine 2081 rows file to nanjing@aspose.com. Thanks.


#2

Yes. This problem is very strange.

Which version of Aspose.Cells have you tried? And could you send your template file and sample code to nanjing@aspose.com? I will check it ASAP.


#3

I tried Aspose.Cells 3.7.2 and it didn’t work. I am sending you a simple program that will reproduce the corrupt file problem.

Thanks


#4

I didn’t receive your email maybe it’s blocked by email server. Could you post it here? You can make a privte post if you don’t want to disclose it.