We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Could not load file or assembly 'Aspose.Cells, Version=22.3.0.0 deployed in windows azure .net core 3.1

Hi Team,

.Net core 3…1 version and Aspose 22.2.0 version have used ,application working fine local system but deployed in window azure following error we are getting .
Could not load file or assembly ‘Aspose.Cells, Version=22.3.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56’. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly ‘Aspose.Cells, Version=22.3.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56’. The system cannot find the file specified.
File name: ‘Aspose.Cells, Version=22.3.0.0, Culture=neutral, PublicKeyToken=716fcc553a201e56’

Pls help us ,it is very urgent to resolve .

Thanks
Sreeni

@sreeni379,

There seems difference in the Aspose.Cells version number b/w your local system and Azure functions. Please make sure that you have added reference to Aspose.Cells for .NET v22.3.0 assembly with its dependencies on azure because as per the exception, it could not find/load the underlying Aspose.Cells for .NET v22.3.0 assembly.

Moreover, if possible, try installing the Aspose.Cells for .NET version from NuGet repos. directly in your project. When you get/install Aspose.Cells from nuget repos., it will automatically install the following additional dependencies (APIs):

otherwise, you got to install these namespaces manually into your project.

Hi Amjad_Sahi ,

As per your suggestion we added those two files in deployment folder but it is not working and also we have tried local server with same but no use .

let me tell you my project folder AProject under this folder have license file Aspose folder and all dlls of Aspose and others dlls under Text AProject ,we tried all way but above same error we have got .

Pls can you share the example project and deployment copy asp.net core application to us.

in My project used Aspose.Cell , Aspose.Pdf and Aspose.Word all three having above same issue not found dll issue

Thanks
Sreeni

@sreeni379,

Could you please create a standalone separate VS.NET sample project with latest version of Aspose.Cells for .NET, zip the project and share it with us to reproduce the issue on our end. We will check your issue soon.

@Amjad_Sahi- As per the company policy I am not able to share ,As per my previous post , pls share example project of net core 3.1 include version 22.3…0.0 cell working deploy in iis server , we will follow same and let’s see the any issue is there issue with our code example .

Thanks
Sreeni

I did create a new ASP.NET Core 3.1 web application in VS.NET 2022 and used/imported latest version of Aspose.Cells for .NET in it. I tested a simple sample code to save a workbook/Excel file. Everything works fine on my end. I have shared my sample project via Google drive here. You may download and and run it in your VS.NET and you will see there is no such error (as you mentioned in the first post in the thread). By the way, I do not think my attached project will help you much as it is just simple sample project and I executed using IISExpress on my pc. I did not deploy it on Azure. Your issue seems related to configuration on your end.

If you still could not evaluate or you still find the issue, we again request you to kindly provide a sample (runnable) project to reproduce the issue on our end, we will check it soon.

You may post your issue related to Aspose.Words and Aspose.PDF in their respective forums.