Could not load file or assembly 'Aspose.JavaScript, Version=

I’ve just upgraded my .NET Standard 2.0 Class Library (Core 2.0) project to Aspose.Pdf 17.12 and now I’m getting this error. I didn’t have that with 17.11. What can I do to fix this? Rollback to 17.11?



Thank you for contacting support.

I would like to request you to please share with us a narrowed down sample application reproducing the issue, along with a screenshot of the problem so that we may investigate further to help you out.

Sorry, I just got back to this part of the project again. So I stripped out everything unrelated and there’s 1 test left which fails. Here’s the link to the project Zip -

Run the test and you’ll see the error.

(I tried to upload but my Zip file is slightly bigger than the limit.)

Please look at it sooner then later …


Thank you for sharing requested data.

I have tried to reproduce the problem but the project shared by you is producing an error and I am unable to execute it. Error.JPG Please share a working solution that we can simply execute without confronting any errors.

ok, removed unnecessary dependency -


I have executed the project shared by you but I can not reproduce the mentioned error. Please try using Aspose.PDF for .NET 18.1 in your environment and then share your kind feedback with us.

Excuse me, but I use 18.1 as you may see in the project and in the attached screenshots.2018-01-26_14-43-00.png (11.9 KB)

Plus, I do have an error running the only test in this project. See the screenshot. 2018-01-26_14-43-33.png (97.4 KB)


We have managed to replicate this error in our environment. A ticket with ID PDFNET-44087 has been logged in our issue management system for further investigation and resolution. The issue ID has been linked with this thread so that you will receive notification as soon as the issue is resolved.

We are sorry for the inconvenience.

1 Like

Please fix this asap because client’s app can’t be updated.


I would like to share with you that your issue will be investigated on its due turn. However, we have recorded your concerns and we will notify you once the issue will be resolved. We appreciate your patience in this regard.

got it. thanks!


I would like to share with you that the issues logged under Normal Support are scheduled on first come first serve basis, so the resolution of PDFNET-44087 may take several months. However, we offer Paid Support option to prioritize the issues critical to our customers. Issues logged under Paid Support get higher priority as compared to the issues logged under Free Support. Also, we have dedicated Help Desk for Paid Support customers. If you are interested in Paid Support, you may contact our sales team.

We have been waiting for the netstandard compatible version of Aspose.Pdf before converting some of our projects to netcoreapp/netstandard and we are experiencing the same issue as described above.
If you could please escalate this issue we’d really appreciate it, thank you.


Thank you for contacting support.

This issue has been logged recently and will be investigated and resolved on its due turn. However, we have recorded your concerns and we will notify you once this issue will be resolved. We appreciate your patience and comprehension in this regard.


Thanks for your patience.

We are pleased to inform you that earlier reported issue PDFNET-44087, has been resolved in latest version Aspose.PDF for .NET 18.2. Please try using the latest release version and in case you face any issue, please feel free to contact us.