We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Create a new table type row in MS Word

Hi Noob here,

I am kind of stuck and any any help asap would be really great,
I am trying to edit this existing Aspose document and I’ve to add a new record which itself should be of table type. Please refer attached document Issue.doc where each row in “Coverage and Premiums” table is a table type row.
When I tried to insert a new table type row it is getting merged with the next table type row.

I need to edit the word document and not change the logic in program.

Any help would be greatly appreciated.

Thanks,
Hi Noob,

Thanks for your inquiry. Your input document contains the table with one row in each document's section. Each section have only one table. You need to clone the whole section instead of table's row. Please check following code example. Hope this helps you.

Document doc = new Document(MyDir + "Issue.doc");

// Duplicate the third last section and insert it after it

Section newSection = (Section)doc.Sections[doc.Sections.Count - 3].Clone(true);

doc.InsertAfter(newSection, doc.Sections[doc.Sections.Count - 3]);

doc.Save(MyDir + "Out.docx");

Hi Tahir,

Thanks for your reply, but as I am not writing fresh code for this, but I am doing maintenance for this one and I need to add a new record for a new coverage. So generating the document afresh programmatically is out of scope for me.

Let me explain the scenario once again:
I have a word template, part of which is Issue.doc that I shared. My VB.Net program reads the document and inserts the values for all fields (amount of different coverage). Then there is one logic which reads all the fields and removes the coverage table (entire row) which has $0 amount.

Issue I am facing is that when I try to insert a new table type row it is getting merged with the row behind it. If you refer the attached document, there is one table showing all “Coverage and Premiums” ; in that I need to add a coverage after Dwelling (Coverage A) and it should be a table type row.

Can you help me in that?

Thanks,

Thank you all who’ve tried to help me. I’ve found a solution of this problem. Below are the steps that I did to insert a new row which should be a table type row.
1. Click on the row after which you want to insert a new record.
2. insert a new record.
3. click on the new record then click on page layout menu and insert a section break.
This did the trick for me.

Thanks all

Mods: You can please mark the post as resolved/closed.

Hi Noob,

Thanks for your feedback. It is nice to hear from you that you have solved your query. Please feel free to ask if you have any question about Aspose.Words, we will be happy to help you.