We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Creating pdf from HTML containing special characters and tab spacing

Dear Team,

We have a requirement to create PDF using HTML content. HTML content can contain special characters, tab spacing in content. When we try to generate PDF using this content we are missing the TAB spacings. We tried this with v6.1, v7.6, v9.0. Could you please provide a solution fot this?

Attached screenshot of PDF created using v9.0 highlighted with red boxes in places where tab spacing is expected.

A sample content is given below.

1. This is an
example of a decision, including special characters like “ô” and
“í” and “ã” and other features (like parentheses) and a
noun’s possessive forms. –

a. Some parts of
the text will need to be
indented.

i). and some,
even further;

2. All paragraphs
will also need a tab character between the number and
text, which transfers to the IR intact, and paragraph breaks between
each.


Thanks & Regards,

Anish C

Hi Anish,


Thanks for your inquiry. I am afraid when you open the source HTML in some browser the spaces are adjusted automatically and Aspose.Pdf is doing same. Please check attached image.

Please feel free to contact us for any further assistance.

Best Regards,

Thanks Team for your reply, but could you please provide us a solution on how we can include tabs in PDF created from HTML. Will encoding HTML and passing it to Aspose PDF help in setting tabs as expected? Would be grateful if you could share a code snippet which solves this problem.

Hi Anish,


Thanks for your feedback. After initial investigation, we have logged an enhancement ticket as PDFNEWNET-36892 for your requirements. We will keep you updated about the issue resolution progress via this forum thread.

We are sorry for the inconvenience caused.

Best Regards,

Hi,

Could you please let us know the status? Can we expect a solution soon as we have to implement the requirement at the earliest.

Thanks,

Anish

Hi Anish,


Thanks for your inquiry. I am afraid as we have recently noticed the issue, it is pending for investigation in the queue with other priority tasks. As soon as its investigation completes then we will be in good position to share an ETA. We will keep you updated about the issue resolution progress via this forum thread.

We are sorry for the inconvenience caused.

Best Regards,

Hi Anish,


Thanks for your patience.

We have further investigated the issue PDFNEWNET-36892 reported earlier and it does not seem to be an issue of our API. In order to generate correct output, please try using &nbsp. For your reference, I have also attached the resultant PDF generated over my end.

In the event of any further query, please feel free to contact.